aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-11-16 19:32:31 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2014-11-16 19:32:31 +0100
commit9979d69ff71e3dda418f6d692b727f051d3e4d2b (patch)
tree56f20639c67af1bd3cd79f15d85571b50bf9d998 /doc/CMakeLists.txt
parenta85b594d49e2de3ede79aea425776bf60af8de14 (diff)
downloadyawa-9979d69ff71e3dda418f6d692b727f051d3e4d2b.tar.xz
src/CMakeLists: Build manpage in build directory not src
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index bf45df2..d0d1597 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -5,8 +5,8 @@ add_custom_target(man ALL
-q -b man
-Dversion="${PACKAGE_VERSION}"
"${CMAKE_CURRENT_SOURCE_DIR}"
- "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_BINARY_DIR}"
COMMENT "Building man page with Sphinx"
)
-INSTALL(FILES "yawa.1" DESTINATION "share/man/man1")
+INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/yawa.1" DESTINATION "share/man/man1")