summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-11-12 22:17:20 +0100
committerHolger Levsen <holger@layer-acht.org>2012-11-12 22:17:20 +0100
commitb130b8f2d97e6f62111420ca82b427439b741d3f (patch)
tree3e0558c4a8eefafe451c01008c6795a38f5c4bf0 /bin/d-i_build.sh
parent8cf7c6005377153930a8f0c2f87b62493d4a24a0 (diff)
downloadjenkins.debian.net-b130b8f2d97e6f62111420ca82b427439b741d3f.tar.xz
fixup: check if we need to do anything
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 3f1ef94b..77d929c8 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -31,10 +31,10 @@ pdebuild_package() {
# check if we need to do anything
#
ARCH=$(dpkg --print-architecture)
- EGREP_PATTERN="'( all| any| $ARCH)'"
- if [ ! $(grep Architecture: debian/control | egrep -q $EGREP_PATTERN) ] ; then
- echo "This package is not to be supposed to be build on $ARCH."
- grep Architecture: debian/control
+ EGREP_PATTERN="( all| any| $ARCH)"
+ if [ ! $(grep "Architecture:" debian/control | egrep -q '$EGREP_PATTERN') ] ; then
+ echo "This package is not to be supposed to be build on $ARCH:"
+ grep "Architecture:" debian/control
return
fi