summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/d-i_build.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 3f1ef94b..77d929c8 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -31,10 +31,10 @@ pdebuild_package() {
# check if we need to do anything
#
ARCH=$(dpkg --print-architecture)
- EGREP_PATTERN="'( all| any| $ARCH)'"
- if [ ! $(grep Architecture: debian/control | egrep -q $EGREP_PATTERN) ] ; then
- echo "This package is not to be supposed to be build on $ARCH."
- grep Architecture: debian/control
+ EGREP_PATTERN="( all| any| $ARCH)"
+ if [ ! $(grep "Architecture:" debian/control | egrep -q '$EGREP_PATTERN') ] ; then
+ echo "This package is not to be supposed to be build on $ARCH:"
+ grep "Architecture:" debian/control
return
fi