summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-11-12 22:14:01 +0100
committerHolger Levsen <holger@layer-acht.org>2012-11-12 22:14:01 +0100
commit8cf7c6005377153930a8f0c2f87b62493d4a24a0 (patch)
tree2a9e56d661d3ed73e701f29920dfa5eeb4c4b426 /bin/d-i_build.sh
parent8db7d6310a93da3d0f6dc94c84b7e78cc9a58924 (diff)
downloadjenkins.debian.net-8cf7c6005377153930a8f0c2f87b62493d4a24a0.tar.xz
check if we need to do anything
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh20
1 files changed, 12 insertions, 8 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 759fee19..3f1ef94b 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -28,6 +28,17 @@ init_workspace() {
pdebuild_package() {
#
+ # check if we need to do anything
+ #
+ ARCH=$(dpkg --print-architecture)
+ EGREP_PATTERN="'( all| any| $ARCH)'"
+ if [ ! $(grep Architecture: debian/control | egrep -q $EGREP_PATTERN) ] ; then
+ echo "This package is not to be supposed to be build on $ARCH."
+ grep Architecture: debian/control
+ return
+ fi
+
+ #
# prepare build
#
if [ ! -f /var/cache/pbuilder/base.tgz ] ; then
@@ -39,14 +50,7 @@ pdebuild_package() {
#
# build
#
- ARCH=$(dpkg --print-architecture)
- EGREP_PATTERN="'( all| any| $ARCH)'"
- if [ $(grep Architecture: debian/control | egrep -q $EGREP_PATTERN) ] ; then
- pdebuild
- else
- echo "This package is not to be supposed to be build on $ARCH."
- grep Architecture: debian/control
- fi
+ pdebuild
}
init_workspace