aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..e5aa8cc
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,9 @@
+find_package(Sphinx REQUIRED)
+
+add_custom_target(man ALL
+ ${SPHINX_EXECUTABLE}
+ -q -b man
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ COMMENT "Building man page with Sphinx"
+)