aboutsummaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-11-11 03:44:47 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2014-11-11 04:19:56 +0100
commit93dc9656e2513d3b350d6a114c92aee64eb76358 (patch)
tree7eca7fa68c76c38c9b16f3ec94edbe715460e7b8 /doc/CMakeLists.txt
parentd40925ddfebdc64e113f63a16beb5b86edf5c297 (diff)
downloadyawa-93dc9656e2513d3b350d6a114c92aee64eb76358.tar.xz
Add initial manapage
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 0000000..e5aa8cc
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,9 @@
+find_package(Sphinx REQUIRED)
+
+add_custom_target(man ALL
+ ${SPHINX_EXECUTABLE}
+ -q -b man
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ COMMENT "Building man page with Sphinx"
+)