aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ea346d..c75092e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,12 +12,9 @@ configure_file(
${CMAKE_SOURCE_DIR}/src/config.h
)
-set(CMAKE_C_COMPILER "clang")
-set(CMAKE_C_FLAGS "-Weverything")
+set(CMAKE_C_COMPILER "clang")
+set(CMAKE_C_FLAGS "-Weverything -std=c11")
set(CMAKE_C_STANDARD 11)
-add_definitions(
- -std=c11
-)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)