aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f5c3504
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required (VERSION 2.6)
+project (hsetroot)
+
+set(PACKAGE_NAME "hsetroot")
+set(PACKAGE_VERSION "1.0.3")
+set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
+set(PACKAGE_DESCRIPTION "yet another wallpaper application")
+set(PACKAGE_BUGREPORT "johannes@kyriasis.com")
+
+configure_file(
+ ${CMAKE_SOURCE_DIR}/src/config.h.in
+ ${CMAKE_SOURCE_DIR}/src/config.h
+)
+
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
+
+add_subdirectory("src")