summaryrefslogtreecommitdiffstats
path: root/job-cfg/dvswitch.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'job-cfg/dvswitch.yaml')
-rw-r--r--job-cfg/dvswitch.yaml95
1 files changed, 0 insertions, 95 deletions
diff --git a/job-cfg/dvswitch.yaml b/job-cfg/dvswitch.yaml
deleted file mode 100644
index 294f7e7f..00000000
--- a/job-cfg/dvswitch.yaml
+++ /dev/null
@@ -1,95 +0,0 @@
-- defaults:
- name: dvswitch
- project-type: freestyle
- properties:
- - sidebar:
- url: https://jenkins.debian.net/userContent/about.html
- text: About jenkins.debian.net
- icon: /userContent/images/debian-swirl-24x24.png
- - sidebar:
- url: https://jenkins.debian.net/view/dvswitch/
- text: dvswitch test jobs
- icon: /userContent/images/debian-jenkins-24x24.png
- - sidebar:
- url: http://www.profitbricks.co.uk
- text: Sponsored by Profitbricks
- icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/dvswitch.yaml">dvswitch.yaml</a>.'
- logrotate:
- daysToKeep: 90
- numToKeep: 30
- artifactDaysToKeep: -1
- artifactNumToKeep: -1
- scm:
- - git:
- url: 'git://anonscm.debian.org/dvswitch/dvswitch.git'
- branches:
- - master
- builders:
- - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_jessie'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org dvswitch-maint@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_stretch'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org dvswitch-maint@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_sid'
- triggers:
- - pollscm: '*/6 * * * *'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org wouter@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_against_libav_git'
- triggers:
- - timed: '0 1 * * *' # every day at 01:00 UTC
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org wouter@debian.org'
- scm:
- - git:
- url: 'git://git.libav.org/libav.git'
- branches:
- - master
-
-- project:
- name: dvswitch
- jobs:
- - '{name}_sid':
- my_distro: 'sid'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on sid.'
- my_trigger: 'dvswitch_stretch'
- - '{name}_stretch':
- my_distro: 'stretch'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on stretch.'
- my_trigger: 'dvswitch_jessie'
- - '{name}_jessie':
- my_distro: 'jessie'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on jessie.'
- my_trigger: ''
- - '{name}_against_libav_git':
- my_distro: 'sid'
- my_shell: '"apt-get -y build-dep dvswitch libav ; ./configure --enable-shared --disable-static ; make ; make install ; cd .. ; git clone git://anonscm.debian.org/dvswitch/dvswitch.git ; cd dvswitch ; mk-build-deps -ir ; apt-get -y remove libavcodec-dev libavutil-dev ; ./debian/rules build"'
- my_description: 'Build the dvswitch git master branch on sid.'