summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README7
-rwxr-xr-xdeploy_kgb.py1
-rw-r--r--job-cfg/dvswitch.yaml95
3 files changed, 0 insertions, 103 deletions
diff --git a/README b/README
index c9d1a7b2..493bf7c5 100644
--- a/README
+++ b/README
@@ -175,13 +175,6 @@ jenkins@jenkins:~$ /srv/jenkins/bin/reproducible_blacklist.sh $suite $package1
* Finally, there are also three jobs testing the link:http://www.coreboot.org/[coreboot], link:https://openwrt.org/[OpenWrt] and link:http://www.netbsd.org/[NetBSD] projects. The results of the tests can be seen respectively at https://reproducible.debian.net/coreboot/, https://reproducible.debian.net/openwrt/ and https://reproducible.debian.net/netbsd/.
-=== dvswitch jobs
-
-* There are three jobs currently:
-** 'dvswitch_sid' and 'dvswitch_jessie' build the master branch of dvswitch against that environment.
-** while 'dvswitch_against_libav_git' builds the master branch of dvswitch using libav also build from it's master branch. This is done in an sid environment.
-** Except for 'dvswitch_jessie' which is triggered by a successful 'dvswitch_sid' run, the jobs are triggered by git commits.
-
=== jenkins.d.n jobs
These are jobs for making sure jenkins.debian.net is running smoothly.
diff --git a/deploy_kgb.py b/deploy_kgb.py
index ad784b36..cabef236 100755
--- a/deploy_kgb.py
+++ b/deploy_kgb.py
@@ -27,7 +27,6 @@ channels = [
{'name': 'debian-qa', 'id': 'jenkins-debian-qa'},
{'name': 'debian-reproducible', 'id': 'jenkins-debian-reproducible'},
{'name': 'debian-ruby', 'id': 'pkg-ruby-extras'},
- {'name': 'dvswitch', 'id': 'jenkins-dvswitch'},
]
template = """repo-id: '{repo_id}'
diff --git a/job-cfg/dvswitch.yaml b/job-cfg/dvswitch.yaml
deleted file mode 100644
index 294f7e7f..00000000
--- a/job-cfg/dvswitch.yaml
+++ /dev/null
@@ -1,95 +0,0 @@
-- defaults:
- name: dvswitch
- project-type: freestyle
- properties:
- - sidebar:
- url: https://jenkins.debian.net/userContent/about.html
- text: About jenkins.debian.net
- icon: /userContent/images/debian-swirl-24x24.png
- - sidebar:
- url: https://jenkins.debian.net/view/dvswitch/
- text: dvswitch test jobs
- icon: /userContent/images/debian-jenkins-24x24.png
- - sidebar:
- url: http://www.profitbricks.co.uk
- text: Sponsored by Profitbricks
- icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/dvswitch.yaml">dvswitch.yaml</a>.'
- logrotate:
- daysToKeep: 90
- numToKeep: 30
- artifactDaysToKeep: -1
- artifactNumToKeep: -1
- scm:
- - git:
- url: 'git://anonscm.debian.org/dvswitch/dvswitch.git'
- branches:
- - master
- builders:
- - shell: '/srv/jenkins/bin/chroot-run.sh {my_distro} {my_shell}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_jessie'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org dvswitch-maint@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_stretch'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org dvswitch-maint@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_sid'
- triggers:
- - pollscm: '*/6 * * * *'
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org wouter@debian.org'
- - trigger:
- project: '{my_trigger}'
-
-- job-template:
- defaults: dvswitch
- name: '{name}_against_libav_git'
- triggers:
- - timed: '0 1 * * *' # every day at 01:00 UTC
- publishers:
- - email:
- recipients: 'jenkins+dvswitch qa-jenkins-scm@lists.alioth.debian.org wouter@debian.org'
- scm:
- - git:
- url: 'git://git.libav.org/libav.git'
- branches:
- - master
-
-- project:
- name: dvswitch
- jobs:
- - '{name}_sid':
- my_distro: 'sid'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on sid.'
- my_trigger: 'dvswitch_stretch'
- - '{name}_stretch':
- my_distro: 'stretch'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on stretch.'
- my_trigger: 'dvswitch_jessie'
- - '{name}_jessie':
- my_distro: 'jessie'
- my_shell: 'debian/rules build'
- my_description: 'Build the dvswitch git master branch on jessie.'
- my_trigger: ''
- - '{name}_against_libav_git':
- my_distro: 'sid'
- my_shell: '"apt-get -y build-dep dvswitch libav ; ./configure --enable-shared --disable-static ; make ; make install ; cd .. ; git clone git://anonscm.debian.org/dvswitch/dvswitch.git ; cd dvswitch ; mk-build-deps -ir ; apt-get -y remove libavcodec-dev libavutil-dev ; ./debian/rules build"'
- my_description: 'Build the dvswitch git master branch on sid.'