summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-12-10 16:37:53 +0100
committerHolger Levsen <holger@layer-acht.org>2012-12-10 16:37:53 +0100
commit2063764952533636a9167d1570d5aa5103594122 (patch)
tree0f0b6fef067e09acb0772aadb748799dff4f8823 /bin
parent12c556edf81953e4c3f0d87188bc599e5b75fc09 (diff)
downloadjenkins.debian.net-2063764952533636a9167d1570d5aa5103594122.tar.xz
make d-i build jobs end 'unstable' if there is no debian/control
Diffstat (limited to 'bin')
-rwxr-xr-xbin/d-i_build.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index d178dd6e..a70646a5 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -31,8 +31,9 @@ pdebuild_package() {
# check if we need to do anything
#
if [ ! -f debian/control ] ; then
- echo "Oh, a source package without debian/control..."
- exit 1
+ # the Warning: will make the build end in status "unstable" but not "failed"
+ echo "Warning: A source package without debian/control, so no build will be tried."
+ return
fi
ARCH=$(dpkg --print-architecture)
EGREP_PATTERN="( all| any| $ARCH)"