summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/d-i_build.sh5
1 files changed, 3 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index d178dd6e..a70646a5 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -31,8 +31,9 @@ pdebuild_package() {
# check if we need to do anything
#
if [ ! -f debian/control ] ; then
- echo "Oh, a source package without debian/control..."
- exit 1
+ # the Warning: will make the build end in status "unstable" but not "failed"
+ echo "Warning: A source package without debian/control, so no build will be tried."
+ return
fi
ARCH=$(dpkg --print-architecture)
EGREP_PATTERN="( all| any| $ARCH)"