summaryrefslogtreecommitdiffstats
path: root/bin/reproducible_coreboot.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2015-06-12 18:34:44 +0200
committerHolger Levsen <holger@layer-acht.org>2015-06-12 18:34:44 +0200
commite012114406a33674706901b26e8a2784be9944ea (patch)
tree10e6b12f11ca14bfeb5ef27e2627b39f345a9d0e /bin/reproducible_coreboot.sh
parent0a6cbf507fe27be56d2d645d8e336a9352395c4d (diff)
downloadjenkins.debian.net-e012114406a33674706901b26e8a2784be9944ea.tar.xz
use 'ionice -c 3 nice' instead of 'nice ionice -c 3' everywhere
Diffstat (limited to 'bin/reproducible_coreboot.sh')
-rwxr-xr-xbin/reproducible_coreboot.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/reproducible_coreboot.sh b/bin/reproducible_coreboot.sh
index af480d46..87be3064 100755
--- a/bin/reproducible_coreboot.sh
+++ b/bin/reproducible_coreboot.sh
@@ -114,7 +114,7 @@ for ARCH in ${ARCHS} ; do
echo "============================================================================="
echo "$(date -u) - Building cross compiler for ${ARCH}."
# taken from util/crossgcc/Makefile:
- nice ionice -c 3 bash util/crossgcc/buildgcc -j $NUM_CPU -p $ARCH
+ ionice -c 3 nice bash util/crossgcc/buildgcc -j $NUM_CPU -p $ARCH
RESULT=$?
if [ $RESULT -eq 0 ] ; then
GOT_XTOOLCHAIN=true
@@ -155,7 +155,7 @@ sed -i 's#MAKE=$i#MAKE=make#' util/abuild/abuild
sed -i "s#cpus=1#cpus=$NUM_CPU#" util/abuild/abuild
sed -i 's#USE_XARGS=1#USE_XARGS=0#g' util/abuild/abuild
# actually build everything
-nice ionice -c 3 \
+ionice -c 3 nice \
bash util/abuild/abuild --payloads none || true # don't fail the full job just because some targets fail
# save results in b1
@@ -173,7 +173,7 @@ umask 0002
# use allmost all cores for second build
NEW_NUM_CPU=$(echo $NUM_CPU-1|bc)
sed -i "s#cpus=$NUM_CPU#cpus=$NEW_NUM_CPU#" util/abuild/abuild
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
bash util/abuild/abuild --payloads none || true # don't fail the full job just because some targets fail