summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/reproducible_build.sh4
-rwxr-xr-xbin/reproducible_coreboot.sh6
-rwxr-xr-xbin/reproducible_openwrt.sh28
3 files changed, 19 insertions, 19 deletions
diff --git a/bin/reproducible_build.sh b/bin/reproducible_build.sh
index 1a5994d3..5d6cf927 100755
--- a/bin/reproducible_build.sh
+++ b/bin/reproducible_build.sh
@@ -360,7 +360,7 @@ first_build(){
local TMPCFG=$(mktemp -t pbuilderrc_XXXX --tmpdir=$TMPDIR)
set -x
printf "BUILDUSERID=1111\nBUILDUSERNAME=pbuilder1\n" > $TMPCFG
- ( timeout -k 12h 12h nice ionice -c 3 sudo \
+ ( timeout -k 12h 12h ionice -c 3 nice sudo \
DEB_BUILD_OPTIONS="parallel=$NUM_CPU" \
TZ="/usr/share/zoneinfo/Etc/GMT+12" \
pbuilder --build \
@@ -418,7 +418,7 @@ build_rebuild() {
set -x
local TMPCFG=$(mktemp -t pbuilderrc_XXXX --tmpdir=$TMPDIR)
printf "BUILDUSERID=2222\nBUILDUSERNAME=pbuilder2\n" > $TMPCFG
- ( timeout -k 12h 12h nice ionice -c 3 sudo \
+ ( timeout -k 12h 12h ionice -c 3 nice sudo \
DEB_BUILD_OPTIONS="parallel=$(echo $NUM_CPU-1|bc)" \
TZ="/usr/share/zoneinfo/Etc/GMT-14" \
LANG="fr_CH.UTF-8" \
diff --git a/bin/reproducible_coreboot.sh b/bin/reproducible_coreboot.sh
index af480d46..87be3064 100755
--- a/bin/reproducible_coreboot.sh
+++ b/bin/reproducible_coreboot.sh
@@ -114,7 +114,7 @@ for ARCH in ${ARCHS} ; do
echo "============================================================================="
echo "$(date -u) - Building cross compiler for ${ARCH}."
# taken from util/crossgcc/Makefile:
- nice ionice -c 3 bash util/crossgcc/buildgcc -j $NUM_CPU -p $ARCH
+ ionice -c 3 nice bash util/crossgcc/buildgcc -j $NUM_CPU -p $ARCH
RESULT=$?
if [ $RESULT -eq 0 ] ; then
GOT_XTOOLCHAIN=true
@@ -155,7 +155,7 @@ sed -i 's#MAKE=$i#MAKE=make#' util/abuild/abuild
sed -i "s#cpus=1#cpus=$NUM_CPU#" util/abuild/abuild
sed -i 's#USE_XARGS=1#USE_XARGS=0#g' util/abuild/abuild
# actually build everything
-nice ionice -c 3 \
+ionice -c 3 nice \
bash util/abuild/abuild --payloads none || true # don't fail the full job just because some targets fail
# save results in b1
@@ -173,7 +173,7 @@ umask 0002
# use allmost all cores for second build
NEW_NUM_CPU=$(echo $NUM_CPU-1|bc)
sed -i "s#cpus=$NUM_CPU#cpus=$NEW_NUM_CPU#" util/abuild/abuild
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
bash util/abuild/abuild --payloads none || true # don't fail the full job just because some targets fail
diff --git a/bin/reproducible_openwrt.sh b/bin/reproducible_openwrt.sh
index 3e373607..8cc25b31 100755
--- a/bin/reproducible_openwrt.sh
+++ b/bin/reproducible_openwrt.sh
@@ -104,9 +104,9 @@ echo "==========================================================================
echo "$(date -u) - Building the toolchain now."
echo "============================================================================="
make defconfig
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU tools/install
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU toolchain/install
echo "============================================================================="
@@ -114,17 +114,17 @@ echo "$(date -u) - Building openwrt ${OPENWRT_VERSION} images now - first build
echo "============================================================================="
export TZ="/usr/share/zoneinfo/Etc/GMT+12"
# actually build everything
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU target/compile
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU package/cleanup
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU package/compile
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU package/install
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU target/install
-nice ionice -c 3 \
+ionice -c 3 nice \
make -j $NUM_CPU package/index
# save results in b1
@@ -146,22 +146,22 @@ export CAPTURE_ENVIRONMENT="I capture the environment"
umask 0002
# use allmost all cores for second build
NEW_NUM_CPU=$(echo $NUM_CPU-1|bc)
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NUM_CPU target/compile
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NEW_NUM_CPU package/cleanup
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NEW_NUM_CPU package/compile
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NEW_NUM_CPU package/install
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NEW_NUM_CPU target/install
-nice ionice -c 3 \
+ionice -c 3 nice \
linux64 --uname-2.6 \
make -j $NEW_NUM_CPU package/index