summaryrefslogtreecommitdiffstats
path: root/bin/d-i_manual.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-10-14 11:04:13 +0200
committerHolger Levsen <holger@layer-acht.org>2014-10-14 11:04:13 +0200
commit5ef183d2f2c1ec1faac1e55ed1c9061c48e74d20 (patch)
tree765efc72770665797e09218f5a8a101a9008c080 /bin/d-i_manual.sh
parentd45b58ffbf1251467162cd5eacde5833bd244f82 (diff)
downloadjenkins.debian.net-5ef183d2f2c1ec1faac1e55ed1c9061c48e74d20.tar.xz
d-i: cleanup after manual pdbuild
Diffstat (limited to 'bin/d-i_manual.sh')
-rwxr-xr-xbin/d-i_manual.sh3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/d-i_manual.sh b/bin/d-i_manual.sh
index 47680f85..ab1c895c 100755
--- a/bin/d-i_manual.sh
+++ b/bin/d-i_manual.sh
@@ -34,6 +34,9 @@ pdebuild_package() {
cd manual
NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU"
+ # cleanup
+ SOURCE=$(grep "^Source: " debian/control |cut -d " " -f2)
+ sudo dcmd rm /var/cache/pbuilder/result/${SOURCE}_*changes
cd ..
}