summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-10-29 22:44:29 +0100
committerHolger Levsen <holger@layer-acht.org>2014-10-29 22:44:29 +0100
commitaae9522124f6d6d06c8aee72db32fc799a46ccf0 (patch)
treed2f80e95b2187a3bba6b8e3f07ef93c97866b439 /bin/d-i_build.sh
parent3822b6a8312d76ec14e5b51c40e0fd160aa56765 (diff)
downloadjenkins.debian.net-aae9522124f6d6d06c8aee72db32fc799a46ccf0.tar.xz
d-i-build: workaround: #767260 (console-setup doesnt support parallel build)
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh9
1 files changed, 7 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 3b9b411a..19f8746d 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -55,10 +55,15 @@ pdebuild_package() {
#
# build (binary packages only, as sometimes we cannot get the upstream tarball...)
#
- NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
+ SOURCE=$(dpkg-parsechangelog |grep ^Source: | cut -d " " -f2)
+ # FIXME: workaround: #767260 (console-setup doesnt support parallel build)
+ if [ "$SOURCE" != "console-setup" ] ; then
+ NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
+ else
+ NUM_CPU=1
+ fi
pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU -b"
# cleanup
- SOURCE=$(grep "^Source: " debian/control |cut -d " " -f2)
echo
cat /var/cache/pbuilder/result/${SOURCE}_*changes
echo