summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/d-i_build.sh9
1 files changed, 7 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 3b9b411a..19f8746d 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -55,10 +55,15 @@ pdebuild_package() {
#
# build (binary packages only, as sometimes we cannot get the upstream tarball...)
#
- NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
+ SOURCE=$(dpkg-parsechangelog |grep ^Source: | cut -d " " -f2)
+ # FIXME: workaround: #767260 (console-setup doesnt support parallel build)
+ if [ "$SOURCE" != "console-setup" ] ; then
+ NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
+ else
+ NUM_CPU=1
+ fi
pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU -b"
# cleanup
- SOURCE=$(grep "^Source: " debian/control |cut -d " " -f2)
echo
cat /var/cache/pbuilder/result/${SOURCE}_*changes
echo