summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2012-11-12 22:46:09 +0100
committerHolger Levsen <holger@layer-acht.org>2012-11-12 22:46:09 +0100
commit71f37ff35c2abb3a8df5ed26745d35a8c9fd3df9 (patch)
tree4630fc79c9393db10101129762ef6a24b03f91b6 /bin/d-i_build.sh
parentb130b8f2d97e6f62111420ca82b427439b741d3f (diff)
downloadjenkins.debian.net-71f37ff35c2abb3a8df5ed26745d35a8c9fd3df9.tar.xz
fixup
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh8
1 files changed, 6 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 77d929c8..e2287ef8 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -6,7 +6,7 @@
#
# default settings
#
-set -x
+#set -x
set -e
export LC_ALL=C
export MIRROR=http://ftp.de.debian.org/debian
@@ -30,9 +30,13 @@ pdebuild_package() {
#
# check if we need to do anything
#
+ if [ ! -f debian/control ] ; then
+ echo "Oh, a source package without debian/control..."
+ exit 1
+ fi
ARCH=$(dpkg --print-architecture)
EGREP_PATTERN="( all| any| $ARCH)"
- if [ ! $(grep "Architecture:" debian/control | egrep -q '$EGREP_PATTERN') ] ; then
+ if [ ! $(grep "Architecture:" debian/control | egrep "$EGREP_PATTERN" | wc -l ) -gt 0 ] ; then
echo "This package is not to be supposed to be build on $ARCH:"
grep "Architecture:" debian/control
return