summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-10-26 11:09:10 +0100
committerHolger Levsen <holger@layer-acht.org>2014-10-26 11:09:10 +0100
commit3033ea712102f7f18cee1d17a10142e1042d5d94 (patch)
tree52eb091c2d430a1951b99075e877d432c2c9b28d /bin/d-i_build.sh
parent3ae6d8802d2f9d9e697815b7207fb19c7ce8a4cd (diff)
downloadjenkins.debian.net-3033ea712102f7f18cee1d17a10142e1042d5d94.tar.xz
d-i-build: only build binary packages as sometimes we cannot download the orig.tar and then source 3.0 packages would be unhappy
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 879da51d..14d8d75f 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -53,10 +53,10 @@ pdebuild_package() {
fi
#
#
- # build
+ # build (binary packages only, as sometimes we cannot get the upstream tarball...)
#
NUM_CPU=$(cat /proc/cpuinfo |grep ^processor|wc -l)
- pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU"
+ pdebuild --use-pdebuild-internal --debbuildopts "-j$NUM_CPU -b"
# cleanup
SOURCE=$(grep "^Source: " debian/control |cut -d " " -f2)
sudo dcmd rm /var/cache/pbuilder/result/${SOURCE}_*changes