summaryrefslogtreecommitdiffstats
path: root/bin/chroot-run.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-07 00:58:55 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-07 00:58:55 +0200
commitcf51293ad55b4486d1a04b8174bb9ac4b29d882b (patch)
tree3521f3b02ce11b9293085290df3592ee719bfabf /bin/chroot-run.sh
parentde979cd737915c09db0107d2b20195ee510207e2 (diff)
downloadjenkins.debian.net-cf51293ad55b4486d1a04b8174bb9ac4b29d882b.tar.xz
use less sudo
Diffstat (limited to 'bin/chroot-run.sh')
-rwxr-xr-xbin/chroot-run.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index 4193a5ca..8f4a4888 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -80,11 +80,11 @@ cleanup() {
trap cleanup INT TERM EXIT
run() {
- sudo chroot $CHROOT_TARGET mkdir /testrun
- cp -r $CURDIR $CHROOT_TARGET/testrun
+ mkdir $CHROOT_TARGET/tmp/testrun
+ cp -r $CURDIR/* $CHROOT_TARGET/tmp/testrun
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
-cd /testrun
+cd /tmp/testrun
if [ -f debian/control ] ; then
cat debian/control
# install build-depends