summaryrefslogtreecommitdiffstats
path: root/bin/chroot-run.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-04-18 00:19:52 +0200
committerHolger Levsen <holger@layer-acht.org>2014-04-18 00:19:52 +0200
commit4338eae99d4494ba86b398a22247a6bae92f81b7 (patch)
tree9a27551eb85fcec7bb48ec92e6a03062805ab8ed /bin/chroot-run.sh
parentfffff7460269b441da4b824b65fa3c97a4772f61 (diff)
downloadjenkins.debian.net-4338eae99d4494ba86b398a22247a6bae92f81b7.tar.xz
chroot-run.sh: unconditionally install 'build-essential devscripts git' and prepare apt to assume 'yes'
Diffstat (limited to 'bin/chroot-run.sh')
-rwxr-xr-xbin/chroot-run.sh5
1 files changed, 2 insertions, 3 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index ac84614c..d4f6decd 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -93,12 +93,11 @@ run() {
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
cd /tmp/testrun
-apt-get -y install git
+echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
+apt-get install build-essential devscripts git
if [ -f debian/control ] ; then
cat debian/control
# install build-depends
- echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
- apt-get install build-essential devscripts
mk-build-deps -ir
fi
$@