summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xbin/chroot-run.sh5
-rw-r--r--job-cfg/dvswitch.yaml2
2 files changed, 3 insertions, 4 deletions
diff --git a/bin/chroot-run.sh b/bin/chroot-run.sh
index ac84614c..d4f6decd 100755
--- a/bin/chroot-run.sh
+++ b/bin/chroot-run.sh
@@ -93,12 +93,11 @@ run() {
cat > $CHROOT_TARGET/tmp/chroot-testrun <<-EOF
$SCRIPT_HEADER
cd /tmp/testrun
-apt-get -y install git
+echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
+apt-get install build-essential devscripts git
if [ -f debian/control ] ; then
cat debian/control
# install build-depends
- echo 'APT::Get::Assume-Yes "true";' > /etc/apt/apt.conf.d/23jenkins
- apt-get install build-essential devscripts
mk-build-deps -ir
fi
$@
diff --git a/job-cfg/dvswitch.yaml b/job-cfg/dvswitch.yaml
index 1109b9b0..676be7bc 100644
--- a/job-cfg/dvswitch.yaml
+++ b/job-cfg/dvswitch.yaml
@@ -87,5 +87,5 @@
- '{name}_against_libav_git':
my_distro: 'sid'
- my_shell: '"apt-get -y install build-essential devscripts git ; apt-get -y build-dep dvswitch libav ; ./configure ; make ; make install ; cd .. ; git clone git://anonscm.debian.org/dvswitch/dvswitch.git ; cd dvswitch ; mk-build-deps -ir ; ./debian/rules build"'
+ my_shell: '"apt-get -y build-dep dvswitch libav ; ./configure ; make ; make install ; cd .. ; git clone git://anonscm.debian.org/dvswitch/dvswitch.git ; cd dvswitch ; mk-build-deps -ir ; ./debian/rules build"'
my_description: 'Build the dvswitch git master branch on sid.'