summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2016-05-07 13:20:01 +0200
committerHolger Levsen <holger@layer-acht.org>2016-05-07 13:20:01 +0200
commit4d0315d978619ac761a3f9f1ae6d157ffff5a010 (patch)
tree4260f14db0af4eed1009548249766ec0c209352f
parent149c900fd61b8a959ff77e8805e39df76b50b0ff (diff)
downloadjenkins.debian.net-4d0315d978619ac761a3f9f1ae6d157ffff5a010.tar.xz
s#http://anonscm.debian.org/cgit#https://anonscm.debian.org/git#g
-rw-r--r--CONTRIBUTING2
-rw-r--r--README2
-rwxr-xr-xbin/reproducible_common.py4
-rwxr-xr-xbin/reproducible_common.sh6
-rwxr-xr-xbin/reproducible_html_breakages.py2
-rwxr-xr-xbin/reproducible_html_repository_comparison.sh8
-rw-r--r--debian/control2
-rwxr-xr-xjob-cfg/chroot-installation.yaml.py2
-rw-r--r--job-cfg/d-i-overview.yaml2
-rwxr-xr-xjob-cfg/d-i.yaml.py2
-rw-r--r--job-cfg/debsums-tests.yaml2
-rw-r--r--job-cfg/dpkg.yaml2
-rw-r--r--job-cfg/edu-packages.yaml2
-rw-r--r--job-cfg/g-i-installation.yaml2
-rw-r--r--job-cfg/haskell-package-plan.yaml2
-rw-r--r--job-cfg/lintian-tests.yaml2
-rw-r--r--job-cfg/live.yaml2
-rw-r--r--job-cfg/lvc.yaml2
-rw-r--r--job-cfg/piuparts.yaml2
-rwxr-xr-xjob-cfg/rebootstrap.yaml.py2
-rw-r--r--job-cfg/reproducible.yaml2
-rw-r--r--job-cfg/schroot.yaml2
-rw-r--r--job-cfg/self.yaml2
-rw-r--r--job-cfg/torbrowser-launcher.yaml6
-rw-r--r--job-cfg/udd.yaml2
25 files changed, 33 insertions, 33 deletions
diff --git a/CONTRIBUTING b/CONTRIBUTING
index d3e183ea..ddd27e9b 100644
--- a/CONTRIBUTING
+++ b/CONTRIBUTING
@@ -6,7 +6,7 @@ The BTS will ensure the developers' mailing list
debian-qa@lists.debian.org
is notified.
-The code is available in the link:http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/[jenkins.debian.net.git repository].
+The code is available in the link:https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/[jenkins.debian.net.git repository].
Patches can be submitted as requests to pull from a publicly-visible
git repository (this is the prefered way) communicated via IRC or mail,
diff --git a/README b/README
index 38bfc9a1..8e2a652c 100644
--- a/README
+++ b/README
@@ -236,7 +236,7 @@ See link:https://jenkins.debian.net/userContent/thanks.html[THANKS].
== License
* everything except features and bin/libvirt_cucumber_tests:
-** GPLv2, see link:http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/LICENSE[LICENSE].
+** GPLv2, see link:https://anonscm.debian.org/git/qa/jenkins.debian.net.git/LICENSE[LICENSE].
* features and bin/libvirt_cucumber_tests:
** GPLv3+
diff --git a/bin/reproducible_common.py b/bin/reproducible_common.py
index 4e115f49..e40ea276 100755
--- a/bin/reproducible_common.py
+++ b/bin/reproducible_common.py
@@ -145,7 +145,7 @@ else:
JOB_NAME = os.path.basename(JOB_URL[:-1])
JOB_FOOTER = 'This page was built by the jenkins job <a href="'+JOB_URL+'">'
JOB_FOOTER += JOB_NAME+'</a> which is configured via this '
- JOB_FOOTER += '<a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/">git repo</a>.'
+ JOB_FOOTER += '<a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/">git repo</a>.'
html_footer = Template("""
<hr id="footer_separator" /><p style="font-size:0.9em;"><div id="page_footer">
@@ -157,7 +157,7 @@ html_footer = Template("""
<br /> Last update: $date.
Copyright 2014-2016 <a href="mailto:holger@layer-acht.org">Holger Levsen</a>
and <a href="https://jenkins.debian.net//userContent/thanks.html">many others</a>.
- The code of <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/">jenkins.debian.net.git</a> is mostly
+ The code of <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/">jenkins.debian.net.git</a> is mostly
GPL-2 licensed. The weather icons are public domain and have been taken
from the <a href=http://tango.freedesktop.org/Tango_Icon_Library target=_blank>
Tango Icon Library</a>.
diff --git a/bin/reproducible_common.sh b/bin/reproducible_common.sh
index 84e2fc84..eb5fe913 100755
--- a/bin/reproducible_common.sh
+++ b/bin/reproducible_common.sh
@@ -322,7 +322,7 @@ write_page_intro() {
write_page " <p>Please note that this set up is as new as December 12th, so quite some things are still lacking, eg. https://github.com/kholia/ReproducibleBuilds is not followed at all yet and there are no variations introduced for the 2nd build. Also only a subset of all source packages is currently being tested. OTOH this setup is mature enough that it requires very few trivial changes to build all 17080 source packages in $PROJECTNAME, if it were sensible. Which it isn't right now, but should be soon.</p>"
fi
if [ "$1" != "Arch Linux" ] && [ "$1" != "fedora-23" ] ; then
- write_page " <p>There is a weekly run <a href=\"https://jenkins.debian.net/view/reproducible/job/reproducible_$PROJECTNAME/\">jenkins job</a> to test the <code>$BRANCH</code> branch of <a href=\"$PROJECTURL\">$PROJECTNAME.git</a>. The jenkins job is running <a href=\"http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/bin/reproducible_$PROJECTNAME.sh\">reproducible_$PROJECTNAME.sh</a>$BUILD_ENVIRONMENT and this script is solely responsible for creating this page. Feel invited to join <code>#debian-reproducible</code> (on irc.oftc.net) to request job runs whenever sensible. Patches and other <a href=\"mailto:reproducible-builds@lists.alioth.debian.org\">feedback</a> are very much appreciated - if you want to help, please start by looking at the <a href=\"https://jenkins.debian.net/userContent/todo.html#_reproducible_$(echo $1|tr '[:upper:]' '[:lower:]')\">ToDo list for $1</a>, you might find something easy to contribute."
+ write_page " <p>There is a weekly run <a href=\"https://jenkins.debian.net/view/reproducible/job/reproducible_$PROJECTNAME/\">jenkins job</a> to test the <code>$BRANCH</code> branch of <a href=\"$PROJECTURL\">$PROJECTNAME.git</a>. The jenkins job is running <a href=\"https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/bin/reproducible_$PROJECTNAME.sh\">reproducible_$PROJECTNAME.sh</a>$BUILD_ENVIRONMENT and this script is solely responsible for creating this page. Feel invited to join <code>#debian-reproducible</code> (on irc.oftc.net) to request job runs whenever sensible. Patches and other <a href=\"mailto:reproducible-builds@lists.alioth.debian.org\">feedback</a> are very much appreciated - if you want to help, please start by looking at the <a href=\"https://jenkins.debian.net/userContent/todo.html#_reproducible_$(echo $1|tr '[:upper:]' '[:lower:]')\">ToDo list for $1</a>, you might find something easy to contribute."
write_page " <br />Thanks to <a href=\"https://www.profitbricks.co.uk\">Profitbricks</a> for donating the virtual machines this is running on!</p>"
else
write_page " <p>FIXME: explain $PROJECTNAME test setup here.</p>"
@@ -334,11 +334,11 @@ write_page_footer() {
if [ -n "$JOB_URL" ] ; then
write_page "This page was built by the jenkins job"
write_page "<a href=\"$JOB_URL\">$(basename $JOB_URL)</a> which is configured"
- write_page "via this <a href=\"http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/\">git repo</a>."
+ write_page "via this <a href=\"https://anonscm.debian.org/git/qa/jenkins.debian.net.git/\">git repo</a>."
fi
write_page "There is more information <a href=\"https://jenkins.debian.net/userContent/about.html\">about jenkins.debian.net</a> and about <a href=\"https://wiki.debian.org/ReproducibleBuilds\"> reproducible builds of Debian</a> available elsewhere."
write_page "<br /> Last update: $(date +'%Y-%m-%d %H:%M %Z'). Copyright 2014-2016 <a href=\"mailto:holger@layer-acht.org\">Holger Levsen</a> and <a href=\"https://jenkins.debian.net//userContent/thanks.html\">many others</a>."
- write_page "The code of <a href=\"http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/\">jenkins.debian.net.git</a> is mostly GPL-2 licensed. The weather icons are public domain and have been taken from the <a href=\"http://tango.freedesktop.org/Tango_Icon_Library\" target=\"_blank\">Tango Icon Library</a>."
+ write_page "The code of <a href=\"https://anonscm.debian.org/git/qa/jenkins.debian.net.git/\">jenkins.debian.net.git</a> is mostly GPL-2 licensed. The weather icons are public domain and have been taken from the <a href=\"http://tango.freedesktop.org/Tango_Icon_Library\" target=\"_blank\">Tango Icon Library</a>."
write_page "<br />"
if [ "$1" = "coreboot" ] ; then
write_page "The <a href=\"http://www.coreboot.org\">Coreboot</a> logo is Copyright © 2008 by Konsult Stuge and coresystems GmbH and can be freely used to refer to the Coreboot project."
diff --git a/bin/reproducible_html_breakages.py b/bin/reproducible_html_breakages.py
index 8b653b23..f7993927 100755
--- a/bin/reproducible_html_breakages.py
+++ b/bin/reproducible_html_breakages.py
@@ -316,7 +316,7 @@ if __name__ == '__main__':
html = '<p>This page lists unexpected things a human should look at and '
html += 'fix, like packages with an incoherent status or files that '
html += 'should not be there. Some of these breakages are caused by '
- html += 'bugs in <a href="http://anonscm.debian.org/cgit/reproducible/diffoscope.git">diffoscope</a> '
+ html += 'bugs in <a href="https://anonscm.debian.org/git/reproducible/diffoscope.git">diffoscope</a> '
html += 'while others are probably due to bugs in the scripts run by jenkins. '
html += '<em>Please help making this page empty!</em></p>\n'
breakages = gen_html()
diff --git a/bin/reproducible_html_repository_comparison.sh b/bin/reproducible_html_repository_comparison.sh
index 9b72498d..194a777d 100755
--- a/bin/reproducible_html_repository_comparison.sh
+++ b/bin/reproducible_html_repository_comparison.sh
@@ -161,18 +161,18 @@ for PKG in $SOURCEPKGS ; do
GIT="$PKG.git"
case $PKG in
debbindiff)
- URL="http://anonscm.debian.org/cgit/reproducible/diffoscope.git"
+ URL="https://anonscm.debian.org/git/reproducible/diffoscope.git"
GIT="diffoscope.git" ;;
strip-nondeterminism|diffoscope|disorderfs)
- URL="http://anonscm.debian.org/cgit/reproducible/$GIT" ;;
+ URL="https://anonscm.debian.org/git/reproducible/$GIT" ;;
*)
- URL="http://anonscm.debian.org/cgit/reproducible/$GIT/?h=pu/reproducible_builds" ;;
+ URL="https://anonscm.debian.org/git/reproducible/$GIT/?h=pu/reproducible_builds" ;;
esac
custom_curl $URL $TMPFILE
if [ "$(grep "'error'>No repositories found" $TMPFILE 2>/dev/null)" ] ; then
write_row "<span class=\"red\">no git repository found:</span><br />$URL"
elif [ "$(grep "'error'>Invalid branch" $TMPFILE 2>/dev/null)" ] ; then
- URL="http://anonscm.debian.org/cgit/reproducible/$GIT/?h=merged/reproducible_builds"
+ URL="https://anonscm.debian.org/git/reproducible/$GIT/?h=merged/reproducible_builds"
custom_curl $URL $TMPFILE
if [ "$(grep "'error'>Invalid branch" $TMPFILE 2>/dev/null)" ] ; then
if ! $OBSOLETE_IN_SID ; then
diff --git a/debian/control b/debian/control
index 3f25fe10..fb399e71 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Build-Depends: debhelper (>= 9.20120419~), asciidoc
Standards-Version: 3.9.1
Homepage: https://jenkins.debian.net/userContent/about.html
Vcs-Git: git://git.debian.org/git/qa/jenkins.debian.net.git
-Vcs-Browser: http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git
+Vcs-Browser: https://anonscm.debian.org/git/qa/jenkins.debian.net.git
Package: jenkins.debian.net-setup
Architecture: all
diff --git a/job-cfg/chroot-installation.yaml.py b/job-cfg/chroot-installation.yaml.py
index 6a427c20..958dd549 100755
--- a/job-cfg/chroot-installation.yaml.py
+++ b/job-cfg/chroot-installation.yaml.py
@@ -341,7 +341,7 @@ for jobindex, jobspec in enumerate(jobspecs):
data.append({'project': {
'name': 'chroot-installation',
- 'do_not_edit': '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/chroot-installation.yaml.py">chroot-installation.yaml.py</a>.',
+ 'do_not_edit': '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/chroot-installation.yaml.py">chroot-installation.yaml.py</a>.',
'my_prio': '130',
'my_trigger': '',
'my_time': '',
diff --git a/job-cfg/d-i-overview.yaml b/job-cfg/d-i-overview.yaml
index 4ed4b031..9155fd49 100644
--- a/job-cfg/d-i-overview.yaml
+++ b/job-cfg/d-i-overview.yaml
@@ -43,7 +43,7 @@
- project:
name: d-i
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/d-i-overview.yaml.py">d-i-overview.yaml.py</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/d-i-overview.yaml.py">d-i-overview.yaml.py</a>.'
arch:
- amd64
- arm64
diff --git a/job-cfg/d-i.yaml.py b/job-cfg/d-i.yaml.py
index 43450e5c..1b96023f 100755
--- a/job-cfg/d-i.yaml.py
+++ b/job-cfg/d-i.yaml.py
@@ -454,7 +454,7 @@ data.append(
'name': 'd-i',
'do_not_edit': (
'<br><br>Job configuration source is '
- '<a href="http://anonscm.debian.org/cgit/qa/'
+ '<a href="https://anonscm.debian.org/git/qa/'
'jenkins.debian.net.git/tree/job-cfg/d-i.yaml.py">'
'd-i.yaml.py</a>.'),
'jobs': [
diff --git a/job-cfg/debsums-tests.yaml b/job-cfg/debsums-tests.yaml
index 73a2c0bc..2265c34d 100644
--- a/job-cfg/debsums-tests.yaml
+++ b/job-cfg/debsums-tests.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/debsums-tests.yaml">debsums-tests.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/debsums-tests.yaml">debsums-tests.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 30
diff --git a/job-cfg/dpkg.yaml b/job-cfg/dpkg.yaml
index c2d8a8c9..b1219279 100644
--- a/job-cfg/dpkg.yaml
+++ b/job-cfg/dpkg.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/dpkg.yaml">dpkg.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/dpkg.yaml">dpkg.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20
diff --git a/job-cfg/edu-packages.yaml b/job-cfg/edu-packages.yaml
index f20c4b3c..3421ec28 100644
--- a/job-cfg/edu-packages.yaml
+++ b/job-cfg/edu-packages.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Build the master branch of git://anonscm.debian.org/debian-edu/{my_package}.git in sid on every commit.<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/edu-packages.yaml">edu-packages.yaml</a>.'
+ description: 'Build the master branch of git://anonscm.debian.org/debian-edu/{my_package}.git in sid on every commit.<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/edu-packages.yaml">edu-packages.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 30
diff --git a/job-cfg/g-i-installation.yaml b/job-cfg/g-i-installation.yaml
index ddbe7f1a..31c0cdac 100644
--- a/job-cfg/g-i-installation.yaml
+++ b/job-cfg/g-i-installation.yaml
@@ -196,7 +196,7 @@
- project:
name: g-i-installation
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/g-i-installation.yaml">g-i-installation.yaml</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/g-i-installation.yaml">g-i-installation.yaml</a>.'
jobs:
- '{name}_maintenance'
- '{name}_{my_dist}_group':
diff --git a/job-cfg/haskell-package-plan.yaml b/job-cfg/haskell-package-plan.yaml
index 7b2bfedf..16c20ff7 100644
--- a/job-cfg/haskell-package-plan.yaml
+++ b/job-cfg/haskell-package-plan.yaml
@@ -64,7 +64,7 @@
- project:
name: haskell-package-plan
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/haskell-package-plan.yaml">haskell-package-plan.yaml</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/haskell-package-plan.yaml">haskell-package-plan.yaml</a>.'
jobs:
- '{name}':
my_distro: 'sid'
diff --git a/job-cfg/lintian-tests.yaml b/job-cfg/lintian-tests.yaml
index 13be2b34..b25ab32b 100644
--- a/job-cfg/lintian-tests.yaml
+++ b/job-cfg/lintian-tests.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/lintian-tests.yaml">lintian-tests.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/lintian-tests.yaml">lintian-tests.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 30
diff --git a/job-cfg/live.yaml b/job-cfg/live.yaml
index 65490538..6e24894e 100644
--- a/job-cfg/live.yaml
+++ b/job-cfg/live.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/live.yaml">live.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/live.yaml">live.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20
diff --git a/job-cfg/lvc.yaml b/job-cfg/lvc.yaml
index ce3b1770..d9969b93 100644
--- a/job-cfg/lvc.yaml
+++ b/job-cfg/lvc.yaml
@@ -1,7 +1,7 @@
- defaults:
name: lvc
project-type: freestyle
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/lvc.yaml">lvc.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/lvc.yaml">lvc.yaml</a>.'
properties:
- sidebar:
url: https://jenkins.debian.net/userContent/about.html
diff --git a/job-cfg/piuparts.yaml b/job-cfg/piuparts.yaml
index 337b8993..9085d36e 100644
--- a/job-cfg/piuparts.yaml
+++ b/job-cfg/piuparts.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/piuparts.yaml">piuparts.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/piuparts.yaml">piuparts.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20
diff --git a/job-cfg/rebootstrap.yaml.py b/job-cfg/rebootstrap.yaml.py
index e1796b0c..10d332e0 100755
--- a/job-cfg/rebootstrap.yaml.py
+++ b/job-cfg/rebootstrap.yaml.py
@@ -110,7 +110,7 @@ for arch in sorted(architectures):
print("""
- project:
name: rebootstrap
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/rebootstrap.yaml.py">rebootstrap.yaml.py</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/rebootstrap.yaml.py">rebootstrap.yaml.py</a>.'
jobs:""")
for arch in sorted(architectures):
for gccver in sorted(gcc_versions):
diff --git a/job-cfg/reproducible.yaml b/job-cfg/reproducible.yaml
index 2700939f..ac87e4dc 100644
--- a/job-cfg/reproducible.yaml
+++ b/job-cfg/reproducible.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: &desc '{my_description}<br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/reproducible.yaml">reproducible.yaml</a>.<br>Results are available at <a href="https://tests.reproducible-builds.org/">https://tests.reproducible-builds.org</a>.'
+ description: &desc '{my_description}<br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/reproducible.yaml">reproducible.yaml</a>.<br>Results are available at <a href="https://tests.reproducible-builds.org/">https://tests.reproducible-builds.org</a>.'
triggers:
- timed: '{my_timed}'
logrotate:
diff --git a/job-cfg/schroot.yaml b/job-cfg/schroot.yaml
index 2b67ffbd..68401997 100644
--- a/job-cfg/schroot.yaml
+++ b/job-cfg/schroot.yaml
@@ -71,7 +71,7 @@
- project:
name: schroot
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/schroot.yaml">schroot.yaml</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/schroot.yaml">schroot.yaml</a>.'
jobs:
- 'd-i_{name}-sid-create':
my_schroot: d-i-sid
diff --git a/job-cfg/self.yaml b/job-cfg/self.yaml
index dae08e14..d7f7f2d2 100644
--- a/job-cfg/self.yaml
+++ b/job-cfg/self.yaml
@@ -52,7 +52,7 @@
- project:
name: self
- do_not_edit: '<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/self.yaml">self.yaml</a>.'
+ do_not_edit: '<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/self.yaml">self.yaml</a>.'
jobs:
- '{name}_maintenance':
my_shell: '/srv/jenkins/bin/maintenance.sh'
diff --git a/job-cfg/torbrowser-launcher.yaml b/job-cfg/torbrowser-launcher.yaml
index a74bdf27..bc760b79 100644
--- a/job-cfg/torbrowser-launcher.yaml
+++ b/job-cfg/torbrowser-launcher.yaml
@@ -17,7 +17,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
+ description: '{my_description}<br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
logrotate:
daysToKeep: 90
numToKeep: 30
@@ -53,7 +53,7 @@
option: category
categories:
- torbrowser-launcher
- description: '{my_description}<br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
+ description: '{my_description}<br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20
@@ -101,7 +101,7 @@
option: category
categories:
- torbrowser-launcher
- description: '{my_description}<br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
+ description: '{my_description}<br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml">torbrowser-launcher.yaml</a>.<br>Results are available at <a href="https://torbrowser-launcher.debian.net/">https://torbrowser-launcher.debian.net</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20
diff --git a/job-cfg/udd.yaml b/job-cfg/udd.yaml
index 6fb8f348..fad573f5 100644
--- a/job-cfg/udd.yaml
+++ b/job-cfg/udd.yaml
@@ -14,7 +14,7 @@
url: http://www.profitbricks.co.uk
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: '{my_description}<br><br>Job configuration source is <a href="http://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/udd.yaml">udd.yaml</a>.'
+ description: '{my_description}<br><br>Job configuration source is <a href="https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/udd.yaml">udd.yaml</a>.'
logrotate:
daysToKeep: 90
numToKeep: 20