summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2016-05-07 13:16:59 +0200
committerHolger Levsen <holger@layer-acht.org>2016-05-07 13:16:59 +0200
commit149c900fd61b8a959ff77e8805e39df76b50b0ff (patch)
treef6e26a6563e425e7df9352b3505c1e9d555ede9d
parent9ec9086f6e8650819a0fce310312992a55c3d659 (diff)
downloadjenkins.debian.net-149c900fd61b8a959ff77e8805e39df76b50b0ff.tar.xz
s#https://anonscm.debian.org/cgit#https://anonscm.debian.org/git#g
-rw-r--r--README4
-rw-r--r--TODO8
-rwxr-xr-xbin/reproducible_html_notes.py2
-rw-r--r--job-cfg/reproducible.yaml4
4 files changed, 9 insertions, 9 deletions
diff --git a/README b/README
index 533559b0..38bfc9a1 100644
--- a/README
+++ b/README
@@ -154,7 +154,7 @@ Installation tests inside chroot environments.
* Several other jobs exist to build the html pages and to create two JSON files which can be downloaded from https://tests.reproducible-builds.org/reproducible.json and https://tests.reproducible-builds.org/reproducible-tracker.json. The 1st one has all the data (except history) and the 2nd has all the data we consider relevant to bother maintainers with, that is, some ftbfs isses are excluded.
-* Information from https://anonscm.debian.org/cgit/reproducible/notes.git is incorporated on pushes to that git repo.
+* Information from https://anonscm.debian.org/git/reproducible/notes.git is incorporated on pushes to that git repo.
* There are suite specific jobs to create the pbuilder base.tgz's per suite, which have the reproducible apt repo added. Similarly there's another job per suite to create the schroots used by the builder jobs to download the packages sources to build.
@@ -200,7 +200,7 @@ link:https://www.torproject.org/projects/torbrowser.html.en[Tor Browser] is not
There is a link:https://jenkins.debian.net/view/torbrowser/[graphical status overview of torbrowser tests on Debian] which are tests installing torbrowser-launcher on and from sid, stretch, jessie-backports, jessie and wheezy-backports, which first download torbrowser via https and via tor, then launches it to finally connect to a debian mirror via an onion-address and then to www.debian.org. In addition to these there are also tests installing the package from stretch on jessie as well as the package from sid on stretch and jessie. Finally there are also tests for building the package from our git branches for various suites and finally there's a daily build of the package based on the upstream git master branch merged with our sid packaging.
-There are 17 different tests currently and they are configured in just two files, a 220 line link:https://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml[yaml file defining the jenkins jobs] and 528 lines of link:https://anonscm.debian.org/cgit/qa/jenkins.debian.net.git/tree/bin/test_torbrowser-launcher.sh[bash script containing the actual test code].
+There are 17 different tests currently and they are configured in just two files, a 220 line link:https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/job-cfg/torbrowser-launcher.yaml[yaml file defining the jenkins jobs] and 528 lines of link:https://anonscm.debian.org/git/qa/jenkins.debian.net.git/tree/bin/test_torbrowser-launcher.sh[bash script containing the actual test code].
These tests are executed either daily or weekly (those testing the package from ftp.d.o) or on every commit and at least once every month (those testing the package build from git).
diff --git a/TODO b/TODO
index 1c0988bf..5490b6a8 100644
--- a/TODO
+++ b/TODO
@@ -157,7 +157,7 @@ The plan is to run a jenkins.d.o host, which is maintained by DSA, but we are ma
** pkg sets related:
*** add new pkg set: torbrowser-build-depends
*** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential)
-*** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control
+*** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/git/mirror/debian.org.git/plain/debian/control
*** reproducible_create_meta_pkg_sets uses schroot created by dpkg_setup_schroot_jessie job (outside of reproducible job space...)
** "fork" etc/schroot/default into etc/schroot/reproducible
** a reproducible_log_grep_by_sql.(py|sh) would be nice, to only grep in packages with a certain status (build in the last X days)
@@ -177,7 +177,7 @@ The plan is to run a jenkins.d.o host, which is maintained by DSA, but we are ma
* missing tests:
** different cpu type (WIP)
-** prebuilder does (user) group variation like this: https://anonscm.debian.org/cgit/reproducible/misc.git/tree/prebuilder/pbuilderhooks/A02_user
+** prebuilder does (user) group variation like this: https://anonscm.debian.org/git/reproducible/misc.git/tree/prebuilder/pbuilderhooks/A02_user
** variation of $TERM and $COLUMN (and maybe $LINES), unset in the first run, set to "linux" and "77" (and maybe "42") in the 2nd run. maybe vary $SHELL too.
*** actually TERM is set to "linux" by default already, COLUMN is unset
@@ -377,8 +377,8 @@ $ du -hd1 | sort -h | tail -n 6
=== chroot-installation_*
* use schroot for chroot-installation, stop using plain chroot everywhere
-** https://anonscm.debian.org/cgit/mirror/dsa-puppet.git/tree/modules/schroot
-** https://anonscm.debian.org/cgit/mirror/dsa-puppet.git/tree/modules/porterbox/files/dd-schroot-cmd
+** https://anonscm.debian.org/git/mirror/dsa-puppet.git/tree/modules/schroot
+** https://anonscm.debian.org/git/mirror/dsa-puppet.git/tree/modules/porterbox/files/dd-schroot-cmd
** https://gitweb.torproject.org/project/jenkins/tools.git/tree/slaves/linux/build-wrapper
* add alternative tests with aptitude and possible apt
* split etc/schroot/default
diff --git a/bin/reproducible_html_notes.py b/bin/reproducible_html_notes.py
index f7d045f0..6bd1551e 100755
--- a/bin/reproducible_html_notes.py
+++ b/bin/reproducible_html_notes.py
@@ -19,7 +19,7 @@ from reproducible_html_indexes import build_page
NOTES = 'packages.yml'
ISSUES = 'issues.yml'
-NOTESGIT_DESCRIPTION = 'Our notes about issues affecting packages are stored in <a href="https://anonscm.debian.org/cgit/reproducible/notes.git" target="_parent">notes.git</a> and are targeted at packages in Debian in \'unstable/amd64\' (unless they say otherwise).'
+NOTESGIT_DESCRIPTION = 'Our notes about issues affecting packages are stored in <a href="https://anonscm.debian.org/git/reproducible/notes.git" target="_parent">notes.git</a> and are targeted at packages in Debian in \'unstable/amd64\' (unless they say otherwise).'
note_html = Template((tab*2).join("""
<table class="body">
diff --git a/job-cfg/reproducible.yaml b/job-cfg/reproducible.yaml
index f28d46fa..2700939f 100644
--- a/job-cfg/reproducible.yaml
+++ b/job-cfg/reproducible.yaml
@@ -485,11 +485,11 @@
- '{name}_html_{my_reponame}':
my_reponame:
- 'notes':
- my_description: 'Generate HTML results ({my_reponame}) for reproducible builds, triggered by changes to the <a href="https://anonscm.debian.org/cgit/reproducible/{my_reponame}.git" target="_blank">{my_reponame}.git</a> repository.'
+ my_description: 'Generate HTML results ({my_reponame}) for reproducible builds, triggered by changes to the <a href="https://anonscm.debian.org/git/reproducible/{my_reponame}.git" target="_blank">{my_reponame}.git</a> repository.'
my_timed: '57 0 * * *'
my_shell: '/srv/jenkins/bin/reproducible_{my_reponame}.py && /srv/jenkins/bin/reproducible_html_{my_reponame}.py'
- 'source-date-epoch-spec':
- my_description: 'Generate the HTML of the reproducible builds SOURCE_DATE_EPOCH specification, triggered by changes to the <a href="https://anonscm.debian.org/cgit/reproducible/{my_reponame}.git" target="_blank">{my_reponame}.git</a> repository.'
+ my_description: 'Generate the HTML of the reproducible builds SOURCE_DATE_EPOCH specification, triggered by changes to the <a href="https://anonscm.debian.org/git/reproducible/{my_reponame}.git" target="_blank">{my_reponame}.git</a> repository.'
my_timed: ''
my_shell: '/srv/jenkins/bin/reproducible_html_specs.sh {my_reponame}'
my_recipients: 'jenkins+debian-reproducible qa-jenkins-scm@lists.alioth.debian.org'