summaryrefslogtreecommitdiffstats
path: root/git-interface/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'git-interface/Makefile')
-rw-r--r--git-interface/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/git-interface/Makefile b/git-interface/Makefile
new file mode 100644
index 0000000..8865790
--- /dev/null
+++ b/git-interface/Makefile
@@ -0,0 +1,18 @@
+GIT_INTERFACE_DIR := $(abspath $(dir $(lastword $(MAKEFILE_LIST))))
+
+include config.mk
+
+git-auth.sh:
+ sed 's#%GIT_INTERFACE_DIR%#$(GIT_INTERFACE_DIR)#' <git-auth.sh.in >git-auth.sh
+ chmod +x git-auth.sh
+
+install: git-auth.sh
+ install -Dm0755 git-auth.sh "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
+
+uninstall:
+ rm -f "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
+
+clean:
+ rm -f git-auth.sh
+
+.PHONY: install uninstall clean