summaryrefslogtreecommitdiffstats
path: root/git-interface/Makefile
diff options
context:
space:
mode:
authorLukas Fleischer <lfleischer@archlinux.org>2015-06-02 10:48:31 +0200
committerLukas Fleischer <lfleischer@archlinux.org>2015-06-02 10:49:33 +0200
commit124ad009975eb9dfed8141f24fccf12fdc720346 (patch)
tree6ac20eb06f5a89c50182afcf42ad56e70585d1f0 /git-interface/Makefile
parent10ecd3982decc31bda251ec73d00d6a903a75f9f (diff)
downloadaurweb-124ad009975eb9dfed8141f24fccf12fdc720346.tar.xz
Add a Makefile for the git-auth wrapper
Avoid manual editing of the wrapper script when a non-standard path is used. Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
Diffstat (limited to 'git-interface/Makefile')
-rw-r--r--git-interface/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/git-interface/Makefile b/git-interface/Makefile
new file mode 100644
index 0000000..8865790
--- /dev/null
+++ b/git-interface/Makefile
@@ -0,0 +1,18 @@
+GIT_INTERFACE_DIR := $(abspath $(dir $(lastword $(MAKEFILE_LIST))))
+
+include config.mk
+
+git-auth.sh:
+ sed 's#%GIT_INTERFACE_DIR%#$(GIT_INTERFACE_DIR)#' <git-auth.sh.in >git-auth.sh
+ chmod +x git-auth.sh
+
+install: git-auth.sh
+ install -Dm0755 git-auth.sh "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
+
+uninstall:
+ rm -f "$(DESTDIR)$(PREFIX)/bin/aur-git-auth"
+
+clean:
+ rm -f git-auth.sh
+
+.PHONY: install uninstall clean