summaryrefslogtreecommitdiffstats
path: root/web
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-10-21 11:05:51 -0500
committerLukas Fleischer <archlinux@cryptocrack.de>2012-10-22 12:33:11 +0200
commit5222bf09320ebc1cd5da799970fcc0d2dd32bb3f (patch)
tree2a3c1a5018e6898ef5df624b7b53f3d6b998907c /web
parent7e201e5a3a7e85aea89f076b89626604b6b2b7bb (diff)
downloadaurweb-5222bf09320ebc1cd5da799970fcc0d2dd32bb3f.tar.xz
Use HTTPS links everywhere for Arch sites
The main site, wiki, and BBS are using HTTPS exclusively, so link directly to the correct protocol rather than forcing a redirect. Signed-off-by: Dan McGee <dan@archlinux.org> Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
Diffstat (limited to 'web')
-rw-r--r--web/html/home.php10
-rw-r--r--web/html/passreset.php2
-rw-r--r--web/template/header.php8
-rw-r--r--web/template/pkg_details.php2
4 files changed, 11 insertions, 11 deletions
diff --git a/web/html/home.php b/web/html/home.php
index 4d5b699..40ad5fe 100644
--- a/web/html/home.php
+++ b/web/html/home.php
@@ -22,9 +22,9 @@ $dbh = db_connect();
<?php
echo __(
'Welcome to the AUR! Please read the %sAUR User Guidelines%s and %sAUR TU Guidelines%s for more information.',
- '<a href="http://wiki.archlinux.org/index.php/AUR_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/index.php/AUR_User_Guidelines">',
'</a>',
- '<a href="http://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">',
'</a>'
);
?>
@@ -34,7 +34,7 @@ $dbh = db_connect();
echo __(
'Contributed PKGBUILDs %smust%s conform to the %sArch Packaging Standards%s otherwise they will be deleted!',
'<strong>', '</strong>',
- '<a href="http://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
+ '<a href="https://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
'</a>'
);
?>
@@ -48,9 +48,9 @@ $dbh = db_connect();
<?php
echo __(
'General discussion regarding the Arch User Repository (AUR) and Trusted User structure takes place on %saur-general%s. This list can be used for package orphan requests, merge requests, and deletion requests. For discussion relating to the development of the AUR, use the %saur-dev%s mailing list.',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-general">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-general">',
'</a>',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-dev">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-dev">',
'</a>'
);
?>
diff --git a/web/html/passreset.php b/web/html/passreset.php
index 42dfc86..064e3de 100644
--- a/web/html/passreset.php
+++ b/web/html/passreset.php
@@ -100,7 +100,7 @@ html_header(__("Password Reset"));
} else {
?>
<p><?= __('If you have forgotten the e-mail address you used to register, please send a message to the %saur-general%s mailing list.',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-general">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-general">',
'</a>'); ?></p>
<form action="" method="post">
<p><?= __("Enter your e-mail address:"); ?>
diff --git a/web/template/header.php b/web/template/header.php
index 265d638..a60174b 100644
--- a/web/template/header.php
+++ b/web/template/header.php
@@ -13,16 +13,16 @@
</head>
<body>
<div id="archnavbar" class="anb-aur">
- <div id="archnavbarlogo"><h1><a href="http://www.archlinux.org" title="Return to the main page">Arch Linux</a></h1></div>
+ <div id="archnavbarlogo"><h1><a href="https://www.archlinux.org/" title="Return to the main page">Arch Linux</a></h1></div>
<div id="archnavbarmenu">
<ul id="archnavbarlist">
- <li id="anb-home"><a href="http://www.archlinux.org/" title="Arch news, packages, projects and more">Home</a></li>
- <li id="anb-packages"><a href="http://www.archlinux.org/packages/" title="Arch Package Database">Packages</a></li>
+ <li id="anb-home"><a href="https://www.archlinux.org/" title="Arch news, packages, projects and more">Home</a></li>
+ <li id="anb-packages"><a href="https://www.archlinux.org/packages/" title="Arch Package Database">Packages</a></li>
<li id="anb-forums"><a href="https://bbs.archlinux.org/" title="Community forums">Forums</a></li>
<li id="anb-wiki"><a href="https://wiki.archlinux.org/" title="Community documentation">Wiki</a></li>
<li id="anb-bugs"><a href="https://bugs.archlinux.org/" title="Report and track bugs">Bugs</a></li>
<li id="anb-aur"><a href="/" title="Arch Linux User Repository">AUR</a></li>
- <li id="anb-download"><a href="http://www.archlinux.org/download/" title="Get Arch Linux">Download</a></li>
+ <li id="anb-download"><a href="https://www.archlinux.org/download/" title="Get Arch Linux">Download</a></li>
</ul>
</div>
</div><!-- #archnavbar -->
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index 74f9257..1c76557 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -192,7 +192,7 @@ if ($row["MaintainerUID"]):
?>
<li><a href="<?= htmlspecialchars(get_pkg_uri($darr[0]), ENT_QUOTES); ?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1]?>"><?= $darr[0].$darr[1]?></a></li>
<?php else: ?>
- <li><a href="http://www.archlinux.org/packages/?q=<?= urlencode($darr[0])?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1] ?>"><?= $darr[0].$darr[1] ?></a></li>
+ <li><a href="https://www.archlinux.org/packages/?q=<?= urlencode($darr[0])?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1] ?>"><?= $darr[0].$darr[1] ?></a></li>
<?php endif; ?>
<?php endwhile; ?>
</ul>