summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-10-21 11:05:51 -0500
committerLukas Fleischer <archlinux@cryptocrack.de>2012-10-22 12:33:11 +0200
commit5222bf09320ebc1cd5da799970fcc0d2dd32bb3f (patch)
tree2a3c1a5018e6898ef5df624b7b53f3d6b998907c
parent7e201e5a3a7e85aea89f076b89626604b6b2b7bb (diff)
downloadaurweb-5222bf09320ebc1cd5da799970fcc0d2dd32bb3f.tar.xz
Use HTTPS links everywhere for Arch sites
The main site, wiki, and BBS are using HTTPS exclusively, so link directly to the correct protocol rather than forcing a redirect. Signed-off-by: Dan McGee <dan@archlinux.org> Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
-rw-r--r--HACKING2
-rw-r--r--README2
-rw-r--r--TRANSLATING2
-rw-r--r--UPGRADING2
-rw-r--r--support/schema/aur-schema.sql2
-rw-r--r--web/html/home.php10
-rw-r--r--web/html/passreset.php2
-rw-r--r--web/template/header.php8
-rw-r--r--web/template/pkg_details.php2
9 files changed, 16 insertions, 16 deletions
diff --git a/HACKING b/HACKING
index 4f0831c..291da1f 100644
--- a/HACKING
+++ b/HACKING
@@ -32,7 +32,7 @@ Submitting patches
Submit uncompressed git-formatted patches to aur-dev@archlinux.org.
You will need to register on the mailing list before submitting:
-http://mailman.archlinux.org/mailman/listinfo/aur-dev
+https://mailman.archlinux.org/mailman/listinfo/aur-dev
Base your patches on the master branch as forward development is done there.
When writing patches please keep unnecessary changes to a minimum.
diff --git a/README b/README
index 805e0ce..8f6892a 100644
--- a/README
+++ b/README
@@ -64,4 +64,4 @@ Contact:
========
Questions, comments, and patches related to the AUR can be sent to the AUR
development mailing list: aur-dev@archlinux.org
-Mailing list archives: http://mailman.archlinux.org/mailman/listinfo/aur-dev
+Mailing list archives: https://mailman.archlinux.org/mailman/listinfo/aur-dev
diff --git a/TRANSLATING b/TRANSLATING
index d8f1bd4..8f729c8 100644
--- a/TRANSLATING
+++ b/TRANSLATING
@@ -2,7 +2,7 @@ AUR Translation
================
This document describes how to create and maintain AUR translations. It was
-originally derived from http://wiki.archlinux.org/index.php/AUR_Translation
+originally derived from https://wiki.archlinux.org/index.php/AUR_Translation
Creating an AUR translation requires a Transifex (http://www.transifex.net/)
account. You will need to register with a translation team on the AUR project
diff --git a/UPGRADING b/UPGRADING
index a0d4a95..dcf9169 100644
--- a/UPGRADING
+++ b/UPGRADING
@@ -170,7 +170,7 @@ ALTER TABLE PackageCategories MODIFY Category VARCHAR(32) NOT NULL;
ALTER TABLE Packages MODIFY Name VARCHAR(64) NOT NULL,
MODIFY Version VARCHAR(32) NOT NULL DEFAULT '',
MODIFY Description VARCHAR(255) NOT NULL DEFAULT "An Arch Package",
- MODIFY URL VARCHAR(255) NOT NULL DEFAULT "http://www.archlinux.org",
+ MODIFY URL VARCHAR(255) NOT NULL DEFAULT "https://www.archlinux.org",
MODIFY License VARCHAR(40) NOT NULL DEFAULT '';
ALTER TABLE PackageSources
MODIFY Source VARCHAR(255) NOT NULL DEFAULT "/dev/null";
diff --git a/support/schema/aur-schema.sql b/support/schema/aur-schema.sql
index 726fd2f..d55cf1a 100644
--- a/support/schema/aur-schema.sql
+++ b/support/schema/aur-schema.sql
@@ -97,7 +97,7 @@ CREATE TABLE Packages (
Version VARCHAR(32) NOT NULL DEFAULT '',
CategoryID TINYINT UNSIGNED NOT NULL DEFAULT 1,
Description VARCHAR(255) NOT NULL DEFAULT "An Arch Package",
- URL VARCHAR(255) NOT NULL DEFAULT "http://www.archlinux.org",
+ URL VARCHAR(255) NOT NULL DEFAULT "https://www.archlinux.org",
License VARCHAR(40) NOT NULL DEFAULT '',
NumVotes INTEGER UNSIGNED NOT NULL DEFAULT 0,
OutOfDateTS BIGINT UNSIGNED NULL DEFAULT NULL,
diff --git a/web/html/home.php b/web/html/home.php
index 4d5b699..40ad5fe 100644
--- a/web/html/home.php
+++ b/web/html/home.php
@@ -22,9 +22,9 @@ $dbh = db_connect();
<?php
echo __(
'Welcome to the AUR! Please read the %sAUR User Guidelines%s and %sAUR TU Guidelines%s for more information.',
- '<a href="http://wiki.archlinux.org/index.php/AUR_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/index.php/AUR_User_Guidelines">',
'</a>',
- '<a href="http://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">',
+ '<a href="https://wiki.archlinux.org/index.php/AUR_Trusted_User_Guidelines">',
'</a>'
);
?>
@@ -34,7 +34,7 @@ $dbh = db_connect();
echo __(
'Contributed PKGBUILDs %smust%s conform to the %sArch Packaging Standards%s otherwise they will be deleted!',
'<strong>', '</strong>',
- '<a href="http://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
+ '<a href="https://wiki.archlinux.org/index.php/Arch_Packaging_Standards">',
'</a>'
);
?>
@@ -48,9 +48,9 @@ $dbh = db_connect();
<?php
echo __(
'General discussion regarding the Arch User Repository (AUR) and Trusted User structure takes place on %saur-general%s. This list can be used for package orphan requests, merge requests, and deletion requests. For discussion relating to the development of the AUR, use the %saur-dev%s mailing list.',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-general">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-general">',
'</a>',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-dev">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-dev">',
'</a>'
);
?>
diff --git a/web/html/passreset.php b/web/html/passreset.php
index 42dfc86..064e3de 100644
--- a/web/html/passreset.php
+++ b/web/html/passreset.php
@@ -100,7 +100,7 @@ html_header(__("Password Reset"));
} else {
?>
<p><?= __('If you have forgotten the e-mail address you used to register, please send a message to the %saur-general%s mailing list.',
- '<a href="http://mailman.archlinux.org/mailman/listinfo/aur-general">',
+ '<a href="https://mailman.archlinux.org/mailman/listinfo/aur-general">',
'</a>'); ?></p>
<form action="" method="post">
<p><?= __("Enter your e-mail address:"); ?>
diff --git a/web/template/header.php b/web/template/header.php
index 265d638..a60174b 100644
--- a/web/template/header.php
+++ b/web/template/header.php
@@ -13,16 +13,16 @@
</head>
<body>
<div id="archnavbar" class="anb-aur">
- <div id="archnavbarlogo"><h1><a href="http://www.archlinux.org" title="Return to the main page">Arch Linux</a></h1></div>
+ <div id="archnavbarlogo"><h1><a href="https://www.archlinux.org/" title="Return to the main page">Arch Linux</a></h1></div>
<div id="archnavbarmenu">
<ul id="archnavbarlist">
- <li id="anb-home"><a href="http://www.archlinux.org/" title="Arch news, packages, projects and more">Home</a></li>
- <li id="anb-packages"><a href="http://www.archlinux.org/packages/" title="Arch Package Database">Packages</a></li>
+ <li id="anb-home"><a href="https://www.archlinux.org/" title="Arch news, packages, projects and more">Home</a></li>
+ <li id="anb-packages"><a href="https://www.archlinux.org/packages/" title="Arch Package Database">Packages</a></li>
<li id="anb-forums"><a href="https://bbs.archlinux.org/" title="Community forums">Forums</a></li>
<li id="anb-wiki"><a href="https://wiki.archlinux.org/" title="Community documentation">Wiki</a></li>
<li id="anb-bugs"><a href="https://bugs.archlinux.org/" title="Report and track bugs">Bugs</a></li>
<li id="anb-aur"><a href="/" title="Arch Linux User Repository">AUR</a></li>
- <li id="anb-download"><a href="http://www.archlinux.org/download/" title="Get Arch Linux">Download</a></li>
+ <li id="anb-download"><a href="https://www.archlinux.org/download/" title="Get Arch Linux">Download</a></li>
</ul>
</div>
</div><!-- #archnavbar -->
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index 74f9257..1c76557 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -192,7 +192,7 @@ if ($row["MaintainerUID"]):
?>
<li><a href="<?= htmlspecialchars(get_pkg_uri($darr[0]), ENT_QUOTES); ?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1]?>"><?= $darr[0].$darr[1]?></a></li>
<?php else: ?>
- <li><a href="http://www.archlinux.org/packages/?q=<?= urlencode($darr[0])?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1] ?>"><?= $darr[0].$darr[1] ?></a></li>
+ <li><a href="https://www.archlinux.org/packages/?q=<?= urlencode($darr[0])?>" title="<?= __('View packages details for').' '.$darr[0].$darr[1] ?>"><?= $darr[0].$darr[1] ?></a></li>
<?php endif; ?>
<?php endwhile; ?>
</ul>