summaryrefslogtreecommitdiffstats
path: root/xembed/spec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xembed/spec/Makefile.am')
-rw-r--r--xembed/spec/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/xembed/spec/Makefile.am b/xembed/spec/Makefile.am
new file mode 100644
index 0000000..9611f10
--- /dev/null
+++ b/xembed/spec/Makefile.am
@@ -0,0 +1,17 @@
+EXTRA_DIST = xembed-spec.xml
+
+html-build.stamp: xembed-spec.xml
+ sdir=`cd $(srcdir) && pwd` && \
+ rm -rf html && mkdir html && \
+ cd html && \
+ docbook2html $$sdir/xembed-spec.xml && \
+ touch ../html-build.stamp
+
+xembed-spec.ps: xembed-spec.xml
+ docbook2ps $(srcdir)/xembed-spec.xml
+
+all-local: html-build.stamp xembed-spec.ps
+
+clean-local:
+ rm -rf html-build.stamp html xembed-spec.ps
+