summaryrefslogtreecommitdiffstats
path: root/xembed/configure.in
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2012-03-02 15:36:01 +0100
committerVincent Untz <vuntz@gnome.org>2012-03-02 15:36:01 +0100
commit94db110fab0dcea1f8f87efce6ce1be15a67dfc7 (patch)
tree5e04297a2a3a811f9097de50160c4533887a141e /xembed/configure.in
parenta988ef565a037a39aecca754a2f9d2f43e5c5131 (diff)
parent23d7d60971b8428429f120cbf77f3fcf70304b67 (diff)
downloadxdg-specs-94db110fab0dcea1f8f87efce6ce1be15a67dfc7.tar.xz
xembed: Merge import from CVS
Diffstat (limited to 'xembed/configure.in')
-rw-r--r--xembed/configure.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/xembed/configure.in b/xembed/configure.in
new file mode 100644
index 0000000..8e1cbfd
--- /dev/null
+++ b/xembed/configure.in
@@ -0,0 +1,45 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(spec/xembed-spec.xml)
+
+dnl $Format: "AM_INIT_AUTOMAKE(xembed, $ReleaseVersion$)" $
+AM_INIT_AUTOMAKE(xembed, 0.5)
+
+dnl Specify a configuration file
+AM_CONFIG_HEADER(config.h)
+
+dnl Initialize libtool
+AM_PROG_LIBTOOL
+
+dnl Initialize maintainer mode
+AM_MAINTAINER_MODE
+
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_PROG_INSTALL
+
+changequote(,)dnl
+if test "x$GCC" = "xyes"; then
+ case " $CFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wall" ;;
+ esac
+fi
+changequote([,])dnl
+
+dnl Check for GTK+
+dnl
+AM_PATH_GTK_2_0(2.0.0,:, AC_MSG_ERROR([GTK+-2.0.0 or better required]))
+
+dnl Checks for KDE
+dnl
+KDE_USE_QT(3)
+AC_PATH_KDE
+
+dnl Output the Makefiles
+
+AC_OUTPUT([
+Makefile
+spec/Makefile
+tests/Makefile
+])