summaryrefslogtreecommitdiffstats
path: root/xembed/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2002-04-21 13:02:50 +0000
committerOwen Taylor <otaylor@redhat.com>2002-04-21 13:02:50 +0000
commit0384881729afeaa1ff5c6ef1282b1222ebfd7179 (patch)
tree6bb052bd461c4c59514ef1c9f6decf3c7917b6cc /xembed/configure.in
parent19ceb4ed34fd0368294ed42f72e95dfaac4b107e (diff)
downloadxdg-specs-0384881729afeaa1ff5c6ef1282b1222ebfd7179.tar.xz
Sun Apr 21 09:20:30 2002 Owen Taylor <otaylor@redhat.com>
* Reorganize, add test cases in tests/
Diffstat (limited to 'xembed/configure.in')
-rw-r--r--xembed/configure.in45
1 files changed, 45 insertions, 0 deletions
diff --git a/xembed/configure.in b/xembed/configure.in
new file mode 100644
index 0000000..8e1cbfd
--- /dev/null
+++ b/xembed/configure.in
@@ -0,0 +1,45 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(spec/xembed-spec.xml)
+
+dnl $Format: "AM_INIT_AUTOMAKE(xembed, $ReleaseVersion$)" $
+AM_INIT_AUTOMAKE(xembed, 0.5)
+
+dnl Specify a configuration file
+AM_CONFIG_HEADER(config.h)
+
+dnl Initialize libtool
+AM_PROG_LIBTOOL
+
+dnl Initialize maintainer mode
+AM_MAINTAINER_MODE
+
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_PROG_INSTALL
+
+changequote(,)dnl
+if test "x$GCC" = "xyes"; then
+ case " $CFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wall" ;;
+ esac
+fi
+changequote([,])dnl
+
+dnl Check for GTK+
+dnl
+AM_PATH_GTK_2_0(2.0.0,:, AC_MSG_ERROR([GTK+-2.0.0 or better required]))
+
+dnl Checks for KDE
+dnl
+KDE_USE_QT(3)
+AC_PATH_KDE
+
+dnl Output the Makefiles
+
+AC_OUTPUT([
+Makefile
+spec/Makefile
+tests/Makefile
+])