summaryrefslogtreecommitdiffstats
path: root/menu/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2003-10-21 18:59:15 +0000
committerHavoc Pennington <hp@pobox.com>2003-10-21 18:59:15 +0000
commit0763bb19496b63d66f98f0bb1e3d8ce667e8852e (patch)
tree19f8716a68aa069d427ee0479475ecd519c1ff74 /menu/configure.in
parent5958cf9336feeee9ecb5da8671a4663c1e5bffc5 (diff)
downloadxdg-specs-0763bb19496b63d66f98f0bb1e3d8ce667e8852e.tar.xz
create autotools setup
2003-10-21 Havoc Pennington <hp@redhat.com> * create autotools setup
Diffstat (limited to 'menu/configure.in')
-rw-r--r--menu/configure.in61
1 files changed, 61 insertions, 0 deletions
diff --git a/menu/configure.in b/menu/configure.in
new file mode 100644
index 0000000..7a5a76c
--- /dev/null
+++ b/menu/configure.in
@@ -0,0 +1,61 @@
+dnl -*- mode: m4 -*-
+AC_PREREQ(2.52)
+
+AC_INIT(menu-spec.xml)
+
+AM_INIT_AUTOMAKE(desktop-menu-spec, 0.7)
+
+# Honor aclocal flags
+ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+ ## must come before we use the $USE_MAINTAINER_MODE variable later
+AM_MAINTAINER_MODE
+
+AC_ARG_ENABLE(xml-docs, [ --enable-xml-docs build XML into HTML (requires xmlto)],enable_xml_docs=$enableval,enable_xml_docs=auto)
+
+### XML tools
+
+AC_PATH_PROG(XMLTO, xmlto, no)
+
+AC_MSG_CHECKING([whether to build XML documentation])
+
+if test x$XMLTO = xno ; then
+ have_xmlto=no
+else
+ have_xmlto=yes
+fi
+
+if test x$enable_xml_docs = xauto ; then
+ if test x$have_xmlto = xno ; then
+ enable_xml_docs=no
+ else
+ enable_xml_docs=yes
+ fi
+fi
+
+if test x$enable_xml_docs = xyes; then
+ if test x$have_xmlto = xno; then
+ AC_MSG_ERROR([Building XML docs explicitly required, but xmlto not found])
+ fi
+fi
+
+AM_CONDITIONAL(XML_DOCS_ENABLED, test x$enable_xml_docs = xyes)
+AC_MSG_RESULT(yes)
+
+AC_OUTPUT([
+Makefile
+])
+
+dnl ==========================================================================
+echo "
+ Menu specification $VERSION
+ ==============
+
+ prefix: ${prefix}
+ source code location: ${srcdir}
+ xmlto: ${XMLTO}"
+
+echo "
+ Maintainer mode: ${USE_MAINTAINER_MODE}
+ Building XML docs: ${enable_xml_docs}
+"