summaryrefslogtreecommitdiffstats
path: root/autostart/configure.in
diff options
context:
space:
mode:
authorWaldo Bastian <waldo.bastian@intel.com>2006-02-13 20:16:08 +0000
committerWaldo Bastian <waldo.bastian@intel.com>2006-02-13 20:16:08 +0000
commit100928a8e53dafb0fd698028ef464ac9e42bfc86 (patch)
treedb2e2d4e179f156b6e48781e2f817a045d7faa96 /autostart/configure.in
parentb88473fd1ef1f2f20b1e5dfe0023b20042adffb7 (diff)
downloadxdg-specs-100928a8e53dafb0fd698028ef464ac9e42bfc86.tar.xz
Autostart spec added
Diffstat (limited to 'autostart/configure.in')
-rw-r--r--autostart/configure.in61
1 files changed, 61 insertions, 0 deletions
diff --git a/autostart/configure.in b/autostart/configure.in
new file mode 100644
index 0000000..7df76ac
--- /dev/null
+++ b/autostart/configure.in
@@ -0,0 +1,61 @@
+dnl -*- mode: m4 -*-
+AC_PREREQ(2.52)
+
+AC_INIT(autostart-spec.xml)
+
+AM_INIT_AUTOMAKE(autostart-spec, 0.5)
+
+# Honor aclocal flags
+ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+
+ ## must come before we use the $USE_MAINTAINER_MODE variable later
+AM_MAINTAINER_MODE
+
+AC_ARG_ENABLE(xml-docs, [ --enable-xml-docs build XML into HTML (requires xmlto)],enable_xml_docs=$enableval,enable_xml_docs=auto)
+
+### XML tools
+
+AC_PATH_PROG(XMLTO, xmlto, no)
+
+AC_MSG_CHECKING([whether to build XML documentation])
+
+if test x$XMLTO = xno ; then
+ have_xmlto=no
+else
+ have_xmlto=yes
+fi
+
+if test x$enable_xml_docs = xauto ; then
+ if test x$have_xmlto = xno ; then
+ enable_xml_docs=no
+ else
+ enable_xml_docs=yes
+ fi
+fi
+
+if test x$enable_xml_docs = xyes; then
+ if test x$have_xmlto = xno; then
+ AC_MSG_ERROR([Building XML docs explicitly required, but xmlto not found])
+ fi
+fi
+
+AM_CONDITIONAL(XML_DOCS_ENABLED, test x$enable_xml_docs = xyes)
+AC_MSG_RESULT(yes)
+
+AC_OUTPUT([
+Makefile
+])
+
+dnl ==========================================================================
+echo "
+ Autostart specification $VERSION
+ ==============
+
+ prefix: ${prefix}
+ source code location: ${srcdir}
+ xmlto: ${XMLTO}"
+
+echo "
+ Maintainer mode: ${USE_MAINTAINER_MODE}
+ Building XML docs: ${enable_xml_docs}
+"