aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1051cc4..2a8d72a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
-# Contributor: Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
-# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
-
pkgname=openhexagon
pkgver=2.0RC1
pkgrel=1
+
pkgdesc="C++ open source clone of Super Hexagon. (binary)"
-arch=('i686' 'x86_64')
url="http://vittorioromeo.info/projects.html"
-options=(!strip)
+arch=('i686' 'x86_64')
license=('custom:AFL')
+
+options=(!strip)
+
depends=('lua51' 'gcc-libs-multilib' 'mesa' 'libjpeg-turbo' 'sfml')
+
source=(OpenHexagon.tar::'http://vittorioromeo.info/Misc/Temp/OpenHexagon2.0-RC1.xz'
- 'https://raw.github.com/SuperV1234/SSVOpenHexagon/master/LICENSE' OpenHexagon)
+ 'https://raw.github.com/SuperV1234/SSVOpenHexagon/master/LICENSE' OpenHexagon)
+
md5sums=('758df0cb21c5a565f4039c5e0bc6b2c6'
- '2002c3e1decad54ffe535efef6723a5c'
- 'cedfdc5a1bfdf70f730f06466a8d28c5')
+ '2002c3e1decad54ffe535efef6723a5c'
+ 'cedfdc5a1bfdf70f730f06466a8d28c5')
prepare() {
cd testInstall2
@@ -25,6 +26,7 @@ prepare() {
sed -i 's|\./x86|/opt/openhexagon2.0-RC1/x86|g' OpenHexagon
mv ../OpenHexagon .
}
+
package() {
install -d "$pkgdir"/opt/openhexagon2.0-RC1
cp -r testInstall2/* "$pkgdir"/opt/openhexagon2.0-RC1