aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-11-01 19:06:04 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:44 +0200
commitd41e5a33a49eb5dee9aab75b13a4139c4e54fad6 (patch)
tree59ab8ad27a778324f8287dd8dd4f55ad903da28d /PKGBUILD
downloadpkgbuilds-d41e5a33a49eb5dee9aab75b13a4139c4e54fad6.tar.xz
dex-git: import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..d72fb6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=dex-git
+pkgver=0.7.r12.g2d158ca
+pkgrel=1
+
+pkgdesc="Program to execute DesktopEntry files"
+url="https://github.com/jceb/dex"
+license=('GPL2')
+arch=('any')
+
+depends=('python')
+makedepends=('git' 'python-sphinx')
+
+provides=('dex')
+conflicts=('dex')
+
+source=('git+https://github.com/jceb/dex.git')
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd dex
+ git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd dex
+ make
+}
+
+package() {
+ cd dex
+ install -m755 -D dex "$pkgdir"/usr/bin/dex
+ install -D man/dex.1 "$pkgdir"/usr/share/man/man1/dex.1
+}