aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2014-11-19 16:36:41 +0100
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-01 16:03:44 +0200
commit9bfc87fa829f20b9cef93fc4c62e4932aba7fd77 (patch)
treec3d8ce12f1ce94fec88cdd3b18d3a81d27ea4235 /PKGBUILD
downloadpkgbuilds-9bfc87fa829f20b9cef93fc4c62e4932aba7fd77.tar.xz
shaman-git: Import pkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..1cef202
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=shaman-git
+pkgver=0.r248.cb98a17
+pkgrel=1
+
+pkgdesc="A small, native C library and utility to fetch weather"
+url="https://github.com/HalosGhost/shaman"
+arch=('i686' 'x86_64')
+license=('GPL2')
+
+depends=('curl' 'jansson')
+makedepends=('git' 'tup' 'clang')
+
+source=('git+https://github.com/HalosGhost/shaman.git')
+sha256sums=('SKIP')
+
+pkgver () {
+ cd shaman
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd shaman
+ tup upd
+}
+
+check () {
+ cd shaman/test
+ LD_LIBRARY_PATH=../src ./suite
+}
+
+package () {
+ cd shaman
+ DESTDIR="$pkgdir" PREFIX='/usr' ./install.sh
+}