diff options
author | Johannes Löthberg <johannes@kyriasis.com> | 2014-02-10 07:50:01 +0100 |
---|---|---|
committer | Johannes Löthberg <johannes@kyriasis.com> | 2015-06-08 12:02:11 +0200 |
commit | 8670f31779fd0a93fd588a16b641b06caf384d29 (patch) | |
tree | c63009311444bb0114b9add1a48fa56adc2cb632 /PKGBUILD | |
parent | 022ed9abd19403bfbf89474fbc04d7537779c986 (diff) | |
download | pkgbuilds-8670f31779fd0a93fd588a16b641b06caf384d29.tar.xz |
Use git tags for $pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -1,23 +1,24 @@ # Maintainer: Johannes Löthberg <johannes2kyriasis.com> pkgname=python-pafy-git -pkgver=git +pkgver=0.3.33.r0.gc20f6ba pkgrel=1 pkgdesc="Python API for YouTube - Download videos and retrieve metadata from YouTube." arch=('any') url="http://np1.github.io/pafy" license=('GPL3') depends=('python') +conflicts=('python-pafy') source=('git+https://github.com/np1/pafy.git') md5sums=('SKIP') pkgver() { cd pafy - printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" + git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g' } package() { cd pafy python setup.py install --root="$pkgdir" --optimize=1 } -# vim: set ts=2 sts=2 sw=2 noet: +# vim: set ts=4 sts=4 sw=4 noet: |