aboutsummaryrefslogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2013-10-22 19:03:48 +0200
committerJohannes Löthberg <johannes@kyriasis.com>2015-06-08 14:33:41 +0200
commit1e999a47a7403a8f0e6f40ec9751a432f4bab00e (patch)
tree9fe6b6da2aaf6d133026f02ba561bfe24e079547 /PKGBUILD
parentaf74583f5dd72a18f1c96bb66893e038f4767218 (diff)
downloadpkgbuilds-1e999a47a7403a8f0e6f40ec9751a432f4bab00e.tar.xz
did some shit, too lazy to split things up
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1639270..0a8723e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
# Contributor: StephenB <mail4stb at gmail dot com>
+# Contributor: M Rawash <mrawash@gmail.com>
pkgname=urxvt-tabbedex
pkgver=0.4
-pkgrel=2
-pkgdesc="tabbed extension for rxvt-unicode (urxvt) with several extra features, patched for perl 5.18"
+pkgrel=3
+pkgdesc="A tabbed extension for rxvt-unicode with several enhancements"
arch=("any")
url='http://github.com/stepb/urxvt-tabbedex'
license=("GPL")
depends=('rxvt-unicode')
-replaces=('rxvt-unicode-256color-named-tabs')
+makedepends=('git')
+provides=('urxvt-tabbedex')
+conflicts=('urxvt-tabbedex')
install=urxvt-tabbedex.install
-source=("https://github.com/stepb/urxvt-tabbedex/tarball/tabbedex-$pkgver"
- '0001-make-urxvt-tabbedex-work-with-perl-5.18.patch')
-md5sums=('d8c165ae73ae4fa8008e9658c415846d'
- '92d581a40779da3127c88fdc7d10257f')
+source=('git+https://github.com/stepb/urxvt-tabbedex.git#tag=tabbedex-0.4'
+ '0001-make-urxvt-tabbedex-work-with-perl-5.18.patch'
+ 'urxvt-tabbedex.install')
+md5sums=('SKIP'
+ '92d581a40779da3127c88fdc7d10257f'
+ '2b72e16f346240c14bbe27ca23051b7a')
prepare() {
- cd stepb-urxvt-tabbedex-f9490d8
- patch tabbedex ../0001-make-urxvt-tabbedex-work-with-perl-5.18.patch
+ cd urxvt-tabbedex
+ git apply ../0001-make-urxvt-tabbedex-work-with-perl-5.18.patch
}
package() {
- install -Dm644 "$srcdir"/stepb-urxvt-tabbedex-f9490d8/tabbedex \
- "$pkgdir"/usr/lib/urxvt/perl/tabbedex
+ install -Dm644 urxvt-tabbedex/tabbedex "$pkgdir"/usr/lib/urxvt/perl/tabbedex
}
# vim: set ts=4 sw=4 noet: