summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2010-05-04 23:42:01 -0500
committerDan McGee <dan@archlinux.org>2010-05-04 23:42:01 -0500
commiteb6af031ec83c4c0c1d7e12d1cc8f585197c025f (patch)
tree7860f37d4552fa1a66f0dd013cfa935658c71361 /src/util/Makefile.am
parent4f80993933a3feee68758c27c58e9cf5d84bf20e (diff)
downloadpacman-eb6af031ec83c4c0c1d7e12d1cc8f585197c025f.tar.xz
Build vercmp without needing link to libalpm
Include the object file directly from the libalpm version comparison code as it is the only thing we need. This drops the dependency of vercmp on libalpm and all of the stuff we know it drags in. Signed-off-by: Dan McGee <dan@archlinux.org>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 638e2764..7dce9dcc 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -16,7 +16,7 @@ INCLUDES = -I$(top_srcdir)/lib/libalpm
AM_CFLAGS = -pedantic -D_GNU_SOURCE
vercmp_SOURCES = vercmp.c
-vercmp_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
+vercmp_LDADD = $(top_builddir)/lib/libalpm/version.o
testpkg_SOURCES = testpkg.c
testpkg_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la