summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2007-02-12 01:30:02 +0000
committerAaron Griffin <aaron@archlinux.org>2007-02-12 01:30:02 +0000
commit9803ec306691a51db820a7f14fc240eae4c910e8 (patch)
tree644db4dc27f9bbdcacf57bdb4b425866abf24dfd /src/util/Makefile.am
parent67294287e340d0c4c063408f2d1a3360b7ce631e (diff)
downloadpacman-9803ec306691a51db820a7f14fc240eae4c910e8.tar.xz
Added 'testpkg' binary to test for validity of a package:
testpkg <package file>, returns 0 on success, 1 on failure failure will also output error messages to stdout
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 361a742f..8f3a98bd 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -1,7 +1,9 @@
-bin_PROGRAMS = vercmp
+bin_PROGRAMS = vercmp testpkg
AM_CFLAGS = -I$(top_srcdir)/lib/libalpm
vercmp_SOURCES = vercmp.c
+vercmp_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.so
-vercmp_LDADD = $(top_builddir)/lib/libalpm/libalpm.la
+testpkg_SOURCES = testpkg.c
+testpkg_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.so