summaryrefslogtreecommitdiffstats
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <d@falconindy.com>2010-10-12 14:46:12 -0400
committerDan McGee <dan@archlinux.org>2010-12-12 20:21:15 -0600
commit7c06e66c24953a6c8a15e8460be8ed3b1585c469 (patch)
tree724517b0751230e9d9338ab505f1c9a0b1080877 /src/util/Makefile.am
parentabefa23341caa995cc0d155d30baa7faeb7a6c0e (diff)
downloadpacman-7c06e66c24953a6c8a15e8460be8ed3b1585c469.tar.xz
pactree: rewrite in C
Use the bash script in contrib as the basis for a C rewrite using libalpm. The speedup can go from dozens of seconds to less than one second. Colorized output is preserved. The --graph option generates output that graphviz's `dot' utility will understand to draw us a graph. Output is written to stdout and it is left up to the user to pipe the data and determine the output characteristics. Signed-off-by: Dave Reisner <d@falconindy.com> Signed-off-by: Xavier Chantry <chantry.xavier@gmail.com>
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 7dce9dcc..30a2ee35 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -3,7 +3,7 @@ conffile = ${sysconfdir}/pacman.conf
dbpath = ${localstatedir}/lib/pacman/
cachedir = ${localstatedir}/cache/pacman/pkg/
-bin_PROGRAMS = vercmp testpkg testdb cleanupdelta
+bin_PROGRAMS = vercmp testpkg testdb cleanupdelta pactree
DEFS = -DLOCALEDIR=\"@localedir@\" \
-DCONFFILE=\"$(conffile)\" \
@@ -27,5 +27,8 @@ testdb_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
cleanupdelta_SOURCES = cleanupdelta.c
cleanupdelta_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
+pactree_SOURCES = pactree.c
+pactree_LDADD = $(top_builddir)/lib/libalpm/.libs/libalpm.la
+
# vim:set ts=2 sw=2 noet: