summaryrefslogtreecommitdiffstats
path: root/src/pacman/Makefile.am
diff options
context:
space:
mode:
authorAaron Griffin <aaron@archlinux.org>2006-11-14 07:58:42 +0000
committerAaron Griffin <aaron@archlinux.org>2006-11-14 07:58:42 +0000
commit4470e5ce011fef0c918b5c3d1d42ae333fb361ba (patch)
tree5ce8d77cc28f688d53fdea517434f6b1f4f10f10 /src/pacman/Makefile.am
parent7e835366f15f98a1688e022a781483d5c5eeb114 (diff)
downloadpacman-4470e5ce011fef0c918b5c3d1d42ae333fb361ba.tar.xz
* Numerous mini valgrind fixes.
* Addition of hacky architecture check in the _splitname function * Removal of libfetch from the archlinux proper - it has been renamed to libdownload and can be found at http://phraktured.net/libdownload * Merge of _some_ of the Frugalware makepkg change - this may still be incomplete * Removal of libftp from cvs proper * PKGBUILD manpage now says 'PKGBUILD' instead of FrugalBuild (he he)
Diffstat (limited to 'src/pacman/Makefile.am')
-rw-r--r--src/pacman/Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/pacman/Makefile.am b/src/pacman/Makefile.am
index 0e11d82f..956cdecb 100644
--- a/src/pacman/Makefile.am
+++ b/src/pacman/Makefile.am
@@ -6,20 +6,17 @@ localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
AM_CFLAGS = $(CFLAGS) -D_GNU_SOURCE \
- -I$(top_srcdir)/lib/libalpm \
- -I$(top_srcdir)/lib/libfetch
+ -I$(top_srcdir)/lib/libalpm
-pacman_SOURCES = util.c log.c list.c package.c download.c trans.c add.c \
+pacman_SOURCES = util.c log.c list.c package.c downloadprog.c trans.c add.c \
remove.c upgrade.c query.c sync.c conf.c deptest.c pacman.c
pacman_static_SOURCES = $(pacman_SOURCES)
pacman_LDADD = -L$(top_srcdir)/lib/libalpm/.libs \
- -L$(top_srcdir)/lib/libfetch -lfetch \
- -larchive -lm -lalpm -lssl -lcrypto
+ -ldownload -larchive -lm -lalpm -lssl -lcrypto
pacman_static_LDADD = -L$(top_srcdir)/lib/libalpm/.libs/ \
- -L$(top_srcdir)/lib/libfetch -lfetch \
- -larchive -lm -lalpm -lssl -lcrypto
+ -ldownload -larchive -lm -lalpm -lssl -lcrypto
pacman_static_LDFLAGS = $(LDFLAGS) -all-static