summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-03-08 18:08:15 -0600
committerDan McGee <dan@archlinux.org>2012-03-08 18:08:15 -0600
commit8de0631edbd1fd7681f6a924f5e166621328c13f (patch)
tree228db78143b109eeafdcd386354a2e09f561c854 /configure.ac
parentf34864cc9e4e755f2add7581419f4ec1c2525fe0 (diff)
parent1a8c3e52d70bfa21ba108aa77179adf90401949d (diff)
downloadpacman-8de0631edbd1fd7681f6a924f5e166621328c13f.tar.xz
Merge branch 'maint'
Conflicts: lib/libalpm/be_package.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cfd3340f..12a6e65e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,14 +256,14 @@ GCC_VISIBILITY_CC
GCC_GNU89_INLINE_CC
# Host-dependant definitions
-SIZECMD="stat -L -c %s"
+SIZECMD="stat -c %s"
SEDINPLACE="sed -i"
STRIP_BINARIES="--strip-all"
STRIP_SHARED="--strip-unneeded"
STRIP_STATIC="--strip-debug"
case "${host_os}" in
*bsd*)
- SIZECMD="stat -L -f %z"
+ SIZECMD="stat -f %z"
SEDINPLACE="sed -i \"\""
;;
cygwin*)
@@ -272,7 +272,7 @@ case "${host_os}" in
;;
darwin*)
host_os_darwin=yes
- SIZECMD="/usr/bin/stat -L -f %z"
+ SIZECMD="/usr/bin/stat -f %z"
SEDINPLACE="/usr/bin/sed -i ''"
STRIP_BINARIES=""
STRIP_SHARED="-S"