summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-03-30 14:30:08 -0400
committerDave Reisner <dreisner@archlinux.org>2012-04-08 18:48:31 -0400
commit059c572ca5c0f3ac9d90c53f0c0bdc8e4fb0336f (patch)
treec88f0f463a3fbf2b4bed1d7b37e05f9999aed83a /configure.ac
parentc5d951846d6b803909cbd7cfeac643f5feb42911 (diff)
downloadpacman-059c572ca5c0f3ac9d90c53f0c0bdc8e4fb0336f.tar.xz
buildsys: use pkg-config for libarchive detection
This also introduces a versioned dependency of >=2.8.0. Signed-off-by: Dave Reisner <dreisner@archlinux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2fa7634c..1f265cb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,8 +153,8 @@ AC_CHECK_LIB([m], [fabs], ,
AC_MSG_ERROR([libm is needed to compile pacman!]))
# Check for libarchive
-AC_CHECK_LIB([archive], [archive_read_data], ,
- AC_MSG_ERROR([libarchive is needed to compile pacman!]))
+PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 2.8.0], ,
+ AC_MSG_ERROR([*** libarchive >= 2.8.0 is needed to compile pacman!]))
# Check for OpenSSL
have_openssl=no
@@ -412,7 +412,7 @@ ${PACKAGE_NAME}:
preprocessor flags : ${CPPFLAGS}
compiler flags : ${CFLAGS}
defines : ${DEFS}
- library flags : ${LIBS} ${LIBSSL_LIBS}
+ library flags : ${LIBS} ${LIBSSL_LIBS} ${LIBARCHIVE_LIBS}
linker flags : ${LDFLAGS}
Architecture : ${CARCH}