summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index 650b1576..777296de 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -36,8 +36,8 @@ pdebuild_package() {
echo "Warning: A source package without debian/control, so no build will be tried."
return
fi
- if [ $(dh_listpackages | wc -l) -eq 0 ]; then
- echo "This package is not to be supposed to be build on $MYARCH:"
+ if [ $(dh_listpackages | |sed '/^$/d' | wc -l) -eq 0 ]; then
+ echo "This package is not to be supposed to be build on $(dpkg --print-architecture)"
grep "Architecture:" debian/control
return
fi