summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh12
1 files changed, 4 insertions, 8 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index f5dc063e..650b1576 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -36,14 +36,10 @@ pdebuild_package() {
echo "Warning: A source package without debian/control, so no build will be tried."
return
fi
- ARCH=$(grep 'Architecture:' debian/control | cut -d' ' -f 2)
- MYARCH=$(dpkg --print-architecture)
- if [ $ARCH != "all" ] ; then
- if ! dpkg-architecture -i$ARCH ; then
- echo "This package is not to be supposed to be build on $MYARCH:"
- grep "Architecture:" debian/control
- return
- fi
+ if [ $(dh_listpackages | wc -l) -eq 0 ]; then
+ echo "This package is not to be supposed to be build on $MYARCH:"
+ grep "Architecture:" debian/control
+ return
fi
#
# prepare build