summaryrefslogtreecommitdiffstats
path: root/bin/d-i_build.sh
diff options
context:
space:
mode:
authorHolger Levsen <holger@layer-acht.org>2014-03-13 19:19:05 +0100
committerHolger Levsen <holger@layer-acht.org>2014-03-13 19:22:39 +0100
commit08ecfd9bbacd2505c2ef2cec56c9511f233d1d59 (patch)
treea54247125a3cac24ad129562408bad087dc6e437 /bin/d-i_build.sh
parent81051c4fc12865b61759801ab2aa5ad00fe9b432 (diff)
downloadjenkins.debian.net-08ecfd9bbacd2505c2ef2cec56c9511f233d1d59.tar.xz
fixup last commit as suggested by Wouter on the list
Diffstat (limited to 'bin/d-i_build.sh')
-rwxr-xr-xbin/d-i_build.sh12
1 files changed, 4 insertions, 8 deletions
diff --git a/bin/d-i_build.sh b/bin/d-i_build.sh
index f5dc063e..650b1576 100755
--- a/bin/d-i_build.sh
+++ b/bin/d-i_build.sh
@@ -36,14 +36,10 @@ pdebuild_package() {
echo "Warning: A source package without debian/control, so no build will be tried."
return
fi
- ARCH=$(grep 'Architecture:' debian/control | cut -d' ' -f 2)
- MYARCH=$(dpkg --print-architecture)
- if [ $ARCH != "all" ] ; then
- if ! dpkg-architecture -i$ARCH ; then
- echo "This package is not to be supposed to be build on $MYARCH:"
- grep "Architecture:" debian/control
- return
- fi
+ if [ $(dh_listpackages | wc -l) -eq 0 ]; then
+ echo "This package is not to be supposed to be build on $MYARCH:"
+ grep "Architecture:" debian/control
+ return
fi
#
# prepare build