summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL34
-rw-r--r--README21
-rw-r--r--TODO7
-rwxr-xr-xupdate_jdn.sh14
4 files changed, 52 insertions, 24 deletions
diff --git a/INSTALL b/INSTALL
new file mode 100644
index 00000000..8f79b6ac
--- /dev/null
+++ b/INSTALL
@@ -0,0 +1,34 @@
+Setup of jenkins.debian.net
+===========================
+:Author: Holger Levsen
+:Authorinitials: holger
+:EMail: holger@layer-acht.org
+:Status: in progress
+:lang: en
+:Doctype: article
+:Licence: GPLv2
+
+== About jenkins.debian.net
+
+See link:http://jenkins.debian.net/userContent/about.html["about jenkins.debian.net"].
+
+== Setup
+
+=== Installed software that makes jenkins.debian.net run
+
+* jenkins.debian.net runs Debian wheezy.
+* FIXME: describe how jenkins is installed + configured, basically put 'deb http://pkg.jenkins-ci.org/debian-stable binary/' into '/etc/apt/sources.list.d/jenkins.list' and `apt-get update`
+* needed packages are listed in 'update_jdn.sh' and which will also make sure they are installed
+** 'update_jdn.sh' is available in the git repo
+* package configuration is kept in that git repo and deployed by 'update_jdn.sh' as well.
+
+=== Installing jenkins-job-builder
+* rebuild python-jenkinsapi from sid for wheezy:
+* `pip install python-jenkins`
+* `git clone https://github.com/openstack-ci/jenkins-job-builder ; cd jenkins-job-builder ; python setup.py install`
+** actually https://github.com/h01ger/jenkins-job-builder is used atm.
+
+=== Using jenkins-job-builder
+
+* then run `cd /srv/jenkins/job-cfg ; jenkins-jobs update .` to update jobs
+* testing: `cd /srv/jenkins/job-cfg ; rm test-output/ -r ; mkdir test-output ; jenkins-jobs test . -o test-output/ ; ls test-output/`
diff --git a/README b/README
index b505e351..40744f3d 100644
--- a/README
+++ b/README
@@ -36,25 +36,8 @@ About jenkins.debian.net
== ToDo
-* There is still a lot of work left, check the current link:http://jenkins.debian.net/userContent/todo.html[ToDo list].
+There is still a lot of work left, check the current link:http://jenkins.debian.net/userContent/todo.html[ToDo list].
== Setup
-=== Installed software that makes jenkins.debian.net run
-
-* jenkins.debian.net runs Debian wheezy.
-* FIXME: describe how jenkins is installed + configured, basically put 'deb http://pkg.jenkins-ci.org/debian-stable binary/' into '/etc/apt/sources.list.d/jenkins.list' and `apt-get update`
-* needed packages are listed in 'update_jdn.sh' and which will also make sure they are installed
-** 'update_jdn.sh' is available in the git repo
-* package configuration is kept in that git repo and deployed by 'update_jdn.sh' as well.
-
-=== Installing jenkins-job-builder
-* rebuild python-jenkinsapi from sid for wheezy:
-* `pip install python-jenkins`
-* `git clone https://github.com/openstack-ci/jenkins-job-builder ; cd jenkins-job-builder ; python setup.py install`
-** actually https://github.com/h01ger/jenkins-job-builder is used atm.
-
-=== Using jenkins-job-builder
-
-* then run `cd /srv/jenkins/job-cfg ; jenkins-jobs update .` to update jobs
-* testing: `cd /srv/jenkins/job-cfg ; rm test-output/ -r ; mkdir test-output ; jenkins-jobs test . -o test-output/ ; ls test-output/`
+See link:http://jenkins.debian.net/userContent/setup.html[INSTALL].
diff --git a/TODO b/TODO
index 4a936820..912ad634 100644
--- a/TODO
+++ b/TODO
@@ -10,11 +10,13 @@ ToDo for jenkins.debian.net
== About jenkins.debian.net
-* see link:http://jenkins.debian.net/userContent/about.html["about jenkins.debian.net"]
+See link:http://jenkins.debian.net/userContent/about.html["about jenkins.debian.net"].
== General ToDo
-* support for gitweb in jobs
+* describe jobs in README
+* support for gitweb in jobs
+** needs clean merge of my patches to jenkins-job-builder first...
* get rid of some reduncacy in job-cfg/*.yaml
* add documentation for jenkins-job-builder and send pull requests on github:
** publisher:logparse
@@ -26,6 +28,7 @@ ToDo for jenkins.debian.net
* proper backup (=daily), see bottom of this document for what to backup
* proper git repo url, outside users/holger
* only trigger (=really run) jobs if available+used packages have changed (save packages in db and compare)
+* update jdk
== More tests to be run
diff --git a/update_jdn.sh b/update_jdn.sh
index c232e1cf..37f0f3d7 100755
--- a/update_jdn.sh
+++ b/update_jdn.sh
@@ -54,13 +54,14 @@ explain "Packages configured."
cd $BASEDIR
cp -r bin logparse job-cfg /srv/jenkins/
explain "Jenkins updated."
-cp -r TODO README userContent/* /var/lib/jenkins/userContent/
+cp -r README INSTALL TODO userContent/* /var/lib/jenkins/userContent/
cd /var/lib/jenkins/userContent/
ASCIIDOC_PARAMS="-a numbered -a data-uri -a iconsdir=/etc/asciidoc/images/icons -a scriptsdir=/etc/asciidoc/javascripts -b html5 -a toc -a toclevels=4 -a icons -a stylesheet=$(pwd)/theme/debian-asciidoc.css"
asciidoc $ASCIIDOC_PARAMS -o about.html README
asciidoc $ASCIIDOC_PARAMS -o todo.html TODO
-rm TODO README
-explain "Updated about.html and todo.html"
+asciidoc $ASCIIDOC_PARAMS -o setup.html INSTALL
+rm TODO README INSTALL
+explain "Updated about.html, setup.html and todo.html."
#
# run jenkins-job-builder to update jobs if needed
@@ -94,3 +95,10 @@ sudo su - jenkins -c "git config --global user.name Jenkins"
# despites the jenkins user cam run "sudo pbuilder" without it just fine...??!
#
sudo chown jenkins /var/cache/pbuilder/result
+
+#
+# There's always some work left...
+#
+echo
+rgrep FIXME $BASEDIR/* | grep -v "rgrep FIXME"
+