summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--TODO2
-rwxr-xr-xbin/reproducible_build.sh4
-rwxr-xr-xbin/reproducible_common.sh4
-rwxr-xr-xbin/reproducible_html_breakages.py4
-rwxr-xr-xbin/reproducible_html_packages.py8
5 files changed, 11 insertions, 11 deletions
diff --git a/TODO b/TODO
index 83664ac9..bf6cee65 100644
--- a/TODO
+++ b/TODO
@@ -186,7 +186,6 @@ This is about Debian, below are more todo entries for other projects…
** check that diffoscope schroot have /usr/bin/ar installed, else fail the job
** check that /srv/workspace/pbuilder/ is cleaned up properly
** right align all numbers in table in the dashboard
-** do final s#debbindiff#diffoscope#g and s#dbd#ds#g and rename .debbindiff.html+txt files as well as the dbd directories...
** pkg sets related:
*** fix essential set: currently it only has the ones explicitly marked Essential:yes; they and their dependencies make up the full "essential closure set" (sometimes also called pseudo-essential)
*** replace bin/reproducible_installed_on_debian.org with a proper data provider from DSA, eg https://anonscm.debian.org/cgit/mirror/debian.org.git/plain/debian/control
@@ -204,6 +203,7 @@ This is about Debian, below are more todo entries for other projects…
** _maintenance.sh: delete the history pages once a page has been removed from all suites+archs
** new page showing arch all packages which are cross-reproducible, and those which are not
** (some!) build jobs should call _build.sh with a third host as param, which is tried as 2nd host if the real 2nd host is down
+** debbindiff2diffoscope rename: do s#dbd#ds#g and s#DBD#DS#g and rename dbd directories?
* missing tests:
** different cpu type (WIP)
diff --git a/bin/reproducible_build.sh b/bin/reproducible_build.sh
index 5c21ce31..1efd321c 100755
--- a/bin/reproducible_build.sh
+++ b/bin/reproducible_build.sh
@@ -515,8 +515,8 @@ get_source_package() {
fi
VERSION="$(grep '^Version: ' ${SRCPACKAGE}_*.dsc| head -1 | egrep -v '(GnuPG v|GnuPG/MacGPG2)' | cut -d ' ' -f2-)"
EVERSION="$(echo $VERSION | cut -d ':' -f2)" # EPOCH_FREE_VERSION was too long
- DBDREPORT="${SRCPACKAGE}_${EVERSION}.debbindiff.html"
- DBDTXT="${SRCPACKAGE}_${EVERSION}.debbindiff.txt"
+ DBDREPORT="${SRCPACKAGE}_${EVERSION}.diffoscope.html"
+ DBDTXT="${SRCPACKAGE}_${EVERSION}.diffoscope.txt"
BUILDINFO="${SRCPACKAGE}_${EVERSION}_${ARCH}.buildinfo"
}
diff --git a/bin/reproducible_common.sh b/bin/reproducible_common.sh
index 467a2f40..4d93af9f 100755
--- a/bin/reproducible_common.sh
+++ b/bin/reproducible_common.sh
@@ -553,8 +553,8 @@ get_filesize() {
cleanup_pkg_files() {
rm -vf $BASE/rbuild/${SUITE}/${ARCH}/${SRCPACKAGE}_*.rbuild.log{,.gz}
rm -vf $BASE/logs/${SUITE}/${ARCH}/${SRCPACKAGE}_*.build?.log{,.gz}
- rm -vf $BASE/dbd/${SUITE}/${ARCH}/${SRCPACKAGE}_*.debbindiff.html
- rm -vf $BASE/dbdtxt/${SUITE}/${ARCH}/${SRCPACKAGE}_*.debbindiff.txt{,.gz}
+ rm -vf $BASE/dbd/${SUITE}/${ARCH}/${SRCPACKAGE}_*.diffoscope.html
+ rm -vf $BASE/dbdtxt/${SUITE}/${ARCH}/${SRCPACKAGE}_*.diffoscope.txt{,.gz}
rm -vf $BASE/buildinfo/${SUITE}/${ARCH}/${SRCPACKAGE}_*.buildinfo
rm -vf $BASE/logdiffs/${SUITE}/${ARCH}/${SRCPACKAGE}_*.diff{,.gz}
}
diff --git a/bin/reproducible_html_breakages.py b/bin/reproducible_html_breakages.py
index 029d94a4..47be0dbc 100755
--- a/bin/reproducible_html_breakages.py
+++ b/bin/reproducible_html_breakages.py
@@ -24,7 +24,7 @@ def unrep_with_dbd_issues():
for pkg, version, suite, arch in results:
eversion = strip_epoch(version)
dbd = DBD_PATH + '/' + suite + '/' + arch + '/' + pkg + '_' + \
- eversion + '.debbindiff.html'
+ eversion + '.diffoscope.html'
if not os.access(dbd, os.R_OK):
without_dbd.append((pkg, version, suite, arch))
log.warning(suite + '/' + arch + '/' + pkg + ' (' + version + ') is '
@@ -51,7 +51,7 @@ def not_unrep_with_dbd_file():
for pkg, version, suite, arch in results:
eversion = strip_epoch(version)
dbd = DBD_PATH + '/' + suite + '/' + arch + '/' + pkg + '_' + \
- eversion + '.debbindiff.html'
+ eversion + '.diffoscope.html'
if os.access(dbd, os.R_OK):
bad_pkgs.append((pkg, version, suite, arch))
log.warning(dbd + ' exists but ' + suite + '/' + arch + '/' + pkg + ' (' + version + ')'
diff --git a/bin/reproducible_html_packages.py b/bin/reproducible_html_packages.py
index 017a33a9..a178330a 100755
--- a/bin/reproducible_html_packages.py
+++ b/bin/reproducible_html_packages.py
@@ -106,13 +106,13 @@ def link_buildlogs(package, eversion, suite, arch):
def link_diffs(package, eversion, suite, arch, status):
html = ''
dbd = DBD_PATH + '/' + suite + '/' + arch + '/' + package + '_' + \
- eversion + '.debbindiff.html'
+ eversion + '.diffoscope.html'
dbdtxt = DBDTXT_PATH + '/' + suite + '/' + arch + '/' + package + '_' + \
- eversion + '.debbindiff.txt.gz'
+ eversion + '.diffoscope.txt.gz'
dbd_url = DBD_URI + '/' + suite + '/' + arch + '/' + package + '_' + \
- eversion + '.debbindiff.html'
+ eversion + '.diffoscope.html'
dbdtxt_url = DBDTXT_URI + '/' + suite + '/' + arch + '/' + package + '_' + \
- eversion + '.debbindiff.txt'
+ eversion + '.diffoscope.txt'
if os.access(dbd, os.R_OK):
html += '<li><a href="' + dbd_url + '" target="main">differences</a>\n'
if os.access(dbdtxt, os.R_OK):