summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README6
-rw-r--r--TODO2
-rw-r--r--job-cfg/d-i.yaml26
3 files changed, 17 insertions, 17 deletions
diff --git a/README b/README
index c9c0130c..210cb4ae 100644
--- a/README
+++ b/README
@@ -65,11 +65,11 @@ Remember, this is still pretty much work in progress. If you can think of ways t
* d_i_build_* - there is one job for each git repo referred to in http://anonscm.debian.org/viewvc/d-i/trunk/.mrconfig?view=co
Each job pdebuilds the master branch of its git repo on every git push in a sid environment. (If the architecture(s) specified in debian/control are not amd64,all or any the build exits cleanly.)
** while these jobs are triggered on commits, the SCM is only polled every 6min to see if there are new commits.
-* d_i_manual - builds the full installation-guide package with pdebuild in sid on every commit to svn://svn.debian.org/svn/d-i/ matching these patterns:
+* d_i_manual - builds the full installation-guide package with pdebuild in sid on every commit to http://anonscm.debian.org/svn/svn/d-i/ matching these patterns:
'/trunk/manual/debian/.\*', '/trunk/manual/po/.\*', '/trunk/manual/doc/.\*' and '/trunk/manual/scripts/.\*'
-** while this job are triggered on commits, the SCM is only polled every 30min to see if there are new commits.
+** while this job is triggered on commits, the SCM is only polled every 15min to see if there are new commits.
* d_i_manual_*_html - builds a language (on wheezy) on every commit of svn/trunk/manual/$LANG with "make languages=$LANG architectures=amd64 formats=html". On successful build, d_i_manual_$lang_pdf is triggered.
-** while these jobs are triggered on commits, the SCM is only polled every 30min to see if there are new commits.
+** while these jobs are triggered on commits, the SCM is only polled every 15min to see if there are new commits.
* d_i_parse_build_logs - parses logs from http://d-i.debian.org/daily-images/build-logs.html daily, to give them a bit more exposure.
** this job is run daily.
diff --git a/TODO b/TODO
index 8d6932a1..9ff5aba0 100644
--- a/TODO
+++ b/TODO
@@ -14,7 +14,7 @@ See link:http://jenkins.debian.net/userContent/about.html["about jenkins.debian.
== General ToDo
-* switch git:// and svn:// urls to http:// and thus use proxy. increase polling frequency to 2min.
+* switch git:// urls to http:// and thus use proxy. increase polling frequency to 2min.
* general housekeeping job:
** run calamaris, visitors etc
** check for stale processes
diff --git a/job-cfg/d-i.yaml b/job-cfg/d-i.yaml
index 2bbd3862..db6dbc54 100644
--- a/job-cfg/d-i.yaml
+++ b/job-cfg/d-i.yaml
@@ -41,10 +41,10 @@
url: http://www.profitbricks.com
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
+ description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
scm:
- svn:
- url: svn://svn.debian.org/svn/d-i/trunk
+ url: http://anonscm.debian.org/svn/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -56,7 +56,7 @@
builders:
- shell: '/srv/jenkins/bin/d-i_manual.sh {lang} html'
triggers:
- - pollscm: "*/30 * * * *"
+ - pollscm: "*/15 * * * *"
publishers:
- trigger:
project: 'd-i_manual_{lang}_pdf'
@@ -70,7 +70,7 @@
indexfiles: ''
keepall: False
- email:
- recipients: jenkins+debian-boot holger@layer-acht.org
+ recipients: holger@layer-acht.org
- defaults:
name: d-i-manual-html-po2xml
@@ -93,10 +93,10 @@
url: http://www.profitbricks.com
text: Sponsored by Profitbricks
icon: /userContent/images/profitbricks-24x24.png
- description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
+ description: 'Builds the {languagename} html version of the installation-guide for all architectures. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/trunk/manual/{lang}/<code>. After successful build <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_pdf</a> is triggered. {do_not_edit}'
scm:
- svn:
- url: svn://svn.debian.org/svn/d-i/trunk
+ url: http://anonscm.debian.org/svn/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/po/{lang}/.*'
@@ -148,7 +148,7 @@
description: 'Builds the {languagename} pdf version of the installation-guide for all architectures. Triggered by successful build of <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_html</a>. {do_not_edit}'
scm:
- svn:
- url: svn://svn.debian.org/svn/d-i/trunk
+ url: http://anonscm.debian.org/svn/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -170,7 +170,7 @@
indexfiles: ''
keepall: False
- email:
- recipients: jenkins+debian-boot holger@layer-acht.org
+ recipients: holger@layer-acht.org
- defaults:
name: d-i-manual-pdf-po2xml
@@ -196,7 +196,7 @@
description: 'Builds the {languagename} pdf version of the installation-guide for all architectures. Triggered by successful build of <a href="http://jenkins.debian.net/job/d-i_manual_{lang}_html">d-i_manual_{lang}_html</a>. {do_not_edit}'
scm:
- svn:
- url: svn://svn.debian.org/svn/d-i/trunk
+ url: http://anonscm.debian.org/svn/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '/trunk/manual/{lang}/.*'
@@ -263,10 +263,10 @@
- job-template:
defaults: d-i
name: '{name}_manual'
- description: 'Builds the installation-guide package. Triggered by SVN commits to <code>svn://svn.debian.org/svn/d-i/</code> matching these patterns: <pre>{include}</pre> {do_not_edit}'
+ description: 'Builds the installation-guide package. Triggered by SVN commits to <code>http://anonscm.debian.org/svn/svn/d-i/</code> matching these patterns: <pre>{include}</pre> {do_not_edit}'
scm:
- svn:
- url: svn://svn.debian.org/svn/d-i/trunk
+ url: http://anonscm.debian.org/svn/svn/d-i/trunk
basedir: .
workspaceupdater: update
includedRegions: '{include}'
@@ -278,10 +278,10 @@
builders:
- shell: '/srv/jenkins/bin/d-i_manual.sh'
triggers:
- - pollscm: "*/30 * * * *"
+ - pollscm: "*/15 * * * *"
publishers:
- email:
- recipients: jenkins+debian-boot holger@layer-acht.org
+ recipients: holger@layer-acht.org
- job-template:
defaults: d-i